Last Comment Bug 654472 - Remove WinCE & Windows Mobile code from embedding/*
: Remove WinCE & Windows Mobile code from embedding/*
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All Windows CE
: -- normal (vote)
: mozilla6
Assigned To: Ed Morley [:emorley]
:
Mentors:
Depends on:
Blocks: 614720
  Show dependency treegraph
 
Reported: 2011-05-03 09:55 PDT by Ed Morley [:emorley]
Modified: 2011-05-06 11:51 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove WinCE code (incl MOZ_FLASH_ACTIVEX_PATCH & USE_HTIFACE) from embedding/* (24.13 KB, patch)
2011-05-03 10:55 PDT, Ed Morley [:emorley]
benjamin: review+
Details | Diff | Review
Remove WinCE code (incl MOZ_FLASH_ACTIVEX_PATCH & USE_HTIFACE) from embedding/* (24.15 KB, patch)
2011-05-06 10:38 PDT, Ed Morley [:emorley]
emorley: review+
Details | Diff | Review

Description Ed Morley [:emorley] 2011-05-03 09:55:32 PDT
WinCE & Windows Mobile code is being slowly removed by bug 614720 - since it's broken, no longer supported, and only serves to complicate code maintenance. 

This bug is for the embedding/* parts of the removal:
http://mxr.mozilla.org/mozilla-central/search?string=wince&find=/embedding/

There isn't a Core::Embedding General component, so filing this in Core::General.
Comment 1 Ed Morley [:emorley] 2011-05-03 10:55:18 PDT
Created attachment 529756 [details] [diff] [review]
Remove WinCE code (incl MOZ_FLASH_ACTIVEX_PATCH & USE_HTIFACE) from embedding/*

Removes WinCE ifdefs from embedding/*, which means:
- MOZ_FLASH_ACTIVEX_PATCH (http://mxr.mozilla.org/mozilla-central/search?string=MOZ_FLASH_ACTIVEX_PATCH)
- USE_HTIFACE (http://mxr.mozilla.org/mozilla-central/search?string=htiface)
...are no longer defined, so can be removed too.

This causes MozActiveX-flash.res to no longer be needed, so have hg removed MozActiveX-flash.rc as well.
Comment 2 Ed Morley [:emorley] 2011-05-03 15:43:38 PDT
Comment on attachment 529756 [details] [diff] [review]
Remove WinCE code (incl MOZ_FLASH_ACTIVEX_PATCH & USE_HTIFACE) from embedding/*

Passed try: http://dev.philringnalda.com/tbpl/?tree=Try&rev=0e42b10dba46
Comment 3 Ed Morley [:emorley] 2011-05-06 10:38:47 PDT
Created attachment 530659 [details] [diff] [review]
Remove WinCE code (incl MOZ_FLASH_ACTIVEX_PATCH & USE_HTIFACE) from embedding/*

Only change is updated commit message to include r=bsmedberg
Carrying forwards r+
Comment 4 Daniel Holbert [:dholbert] 2011-05-06 11:45:53 PDT
http://hg.mozilla.org/mozilla-central/rev/d73c889a6078

Note You need to log in before you can comment on or make changes to this bug.