Last Comment Bug 654552 - Remove WinCE & Windows Mobile code from netwerk/*
: Remove WinCE & Windows Mobile code from netwerk/*
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Networking (show other bugs)
: Trunk
: All Windows CE
: -- normal (vote)
: mozilla6
Assigned To: Ed Morley [:emorley]
:
: Patrick McManus [:mcmanus]
Mentors:
Depends on:
Blocks: 614720
  Show dependency treegraph
 
Reported: 2011-05-03 13:53 PDT by Ed Morley [:emorley]
Modified: 2011-05-08 09:30 PDT (History)
2 users (show)
mounir: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove WinCE code from netwerk/* (26.15 KB, patch)
2011-05-03 14:05 PDT, Ed Morley [:emorley]
cbiesinger: review+
Details | Diff | Splinter Review
Remove WinCE code from netwerk/* (26.17 KB, patch)
2011-05-06 12:50 PDT, Ed Morley [:emorley]
emorley: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2011-05-03 13:53:11 PDT
WinCE & Windows Mobile code is being slowly removed by bug 614720 - since it's broken, no longer supported, and only serves to complicate code maintenance. 

This bug is for the netwerk/* parts of the removal:
http://mxr.mozilla.org/mozilla-central/search?string=wince&find=/netwerk/
Comment 1 Ed Morley [:emorley] 2011-05-03 14:05:47 PDT
Created attachment 529823 [details] [diff] [review]
Remove WinCE code from netwerk/*

Removes WinCE ifdeffed code from netwerk/*

Also hg removes:
- netwerk/base/src/nsAutodialWinCE.(h|cpp)
- netwerk/system/wince/*
Comment 2 Ed Morley [:emorley] 2011-05-04 05:32:19 PDT
Comment on attachment 529823 [details] [diff] [review]
Remove WinCE code from netwerk/*

Passed try: http://dev.philringnalda.com/tbpl/?tree=Try&rev=357126c2abd1
Comment 3 Christian :Biesinger (don't email me, ping me on IRC) 2011-05-06 11:20:32 PDT
Comment on attachment 529823 [details] [diff] [review]
Remove WinCE code from netwerk/*

Review of attachment 529823 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 4 Ed Morley [:emorley] 2011-05-06 12:50:32 PDT
Created attachment 530702 [details] [diff] [review]
Remove WinCE code from netwerk/*

Only change is updated commit message to include r=cbiesinger
Carrying forwards r+
Comment 5 Mounir Lamouri (:mounir) 2011-05-08 09:30:44 PDT
Pushed in mozilla-central:
http://hg.mozilla.org/mozilla-central/rev/23c2ddc386c5

Note You need to log in before you can comment on or make changes to this bug.