Closed Bug 654681 Opened 10 years ago Closed 10 years ago

Email links crash Firefox

Categories

(Firefox :: General, defect)

3.6 Branch
x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 167320

People

(Reporter: derek.logan, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17

Since the upgrade to Firefox 3.6.17 and even installing Firefox 4.0 all email links on any web page opens multiple tabs that keep going till Firefox crashes. I can't even attempt to open the email links in another instance of Firefox because it crashes both instances of Firefox regardless. Everything is okay in version 3.6.16.
This is very urgent because I use email links all the time at work and Firefox is the only browser that consistently lets me work easily and usually without problems.
Any effort someone can give to remedying the problem will be much appreciated. I have noticed others with the same problem but, I did not see any bug reports about it.

Reproducible: Always

Steps to Reproduce:
1.Go to any webpage with an email link.
2.Click on the email link.
3.

Actual Results:  
Using Firefox version 3.6.17 or above, go to any webpage with an email link. Click on that link. Multiple tabs will open and eventually crash Firefox.
The email link can be obtained by right-clicking on the link and selecting to copy it. I can then paste into my email application.

Expected Results:  
Multiple tabs opened and continued to open till Firefox crashed. Even with two instances of Firefox open the problem will cross to the second instance if the first one is closed while producing the multiple tabs and then crash the second instance of Firefox.

The software should simply open my email client (Microsoft outlook 2007) and allow me to continue.
I use Fifeox all the time at work, as do many others as we find it ultimately better and easier to work with than Internet Explorer and all my work bookmarks and links are associated with Firefox.
Not being able to use Firefox will seriously impact the fluidity of my daily routine.
Please help.
Version: unspecified → 3.6 Branch
Please open tools/options/applications and change the mailto entry to something else, click ok, reopen the options and change it back to the value that you want.
[SOLVED] - Open tools/options/applications and change the mailto entry to something else, click ok, reopen the options and change it back to the value that you want.
Thanks Matthias!!!
marking as dupe of bug 167320.
mailto got assigned to Firefox itself somehow and that created a loop.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 167320
You need to log in before you can comment on or make changes to this bug.