Last Comment Bug 654718 - Remove WinCE code from xpfe/*
: Remove WinCE code from xpfe/*
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: All Windows CE
: -- normal (vote)
: mozilla6
Assigned To: Ed Morley [:emorley]
:
Mentors:
Depends on:
Blocks: 614720
  Show dependency treegraph
 
Reported: 2011-05-04 08:33 PDT by Ed Morley [:emorley]
Modified: 2011-05-13 02:14 PDT (History)
4 users (show)
mounir: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove WinCE code from xpfe/* (731 bytes, patch)
2011-05-04 10:15 PDT, Ed Morley [:emorley]
no flags Details | Diff | Review
Remove WinCE code from xpfe (746 bytes, patch)
2011-05-11 09:49 PDT, Ed Morley [:emorley]
khuey: review+
Details | Diff | Review

Description Ed Morley [:emorley] 2011-05-04 08:33:55 PDT
WinCE & Windows Mobile code is being slowly removed by bug 614720 - since it's broken, no longer supported, and only serves to complicate code maintenance. 

This bug is for the xpfe/* parts of the removal:
http://mxr.mozilla.org/mozilla-central/search?string=wince&find=/xpfe/
Comment 1 Ed Morley [:emorley] 2011-05-04 10:15:04 PDT
Created attachment 530062 [details] [diff] [review]
Remove WinCE code from xpfe/*
Comment 2 Ed Morley [:emorley] 2011-05-04 17:58:15 PDT
Comment on attachment 530062 [details] [diff] [review]
Remove WinCE code from xpfe/*

Passed try: http://dev.philringnalda.com/tbpl/?tree=Try&rev=ed18eff9dd9a

Thanks!
Comment 3 neil@parkwaycc.co.uk 2011-05-05 02:23:54 PDT
Comment on attachment 530062 [details] [diff] [review]
Remove WinCE code from xpfe/*

This block is all obsolete with libxul anyway isn't it? IIRC it only existed because MSVC wouldn't inline nsIntRect so shared builds wouldn't link.
Comment 4 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-05-09 12:08:01 PDT
Yeah, this is all obsolete anyways.  Lets just let the "cleanup libxul stuff" bug get this.
Comment 5 Ed Morley [:emorley] 2011-05-09 12:10:18 PDT
Do you mean bug 648911?

If so, it doesn't touch this file. Should it?
Comment 6 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-05-09 12:11:18 PDT
Maybe.  I'd r+ a patch that just removes the whole ifeq block.
Comment 7 Ed Morley [:emorley] 2011-05-09 15:13:15 PDT
What does/did gkgfx do?

MXR doesn't return much for it and the gkgfx seems to no longer exist?
Comment 8 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-05-09 15:20:36 PDT
gkgfx was the shared library that gfx/ ended up in.
Comment 9 Ed Morley [:emorley] 2011-05-11 09:49:28 PDT
Created attachment 531660 [details] [diff] [review]
Remove WinCE code from xpfe

Removes the whole ifeq block, per comment 6 suggestion. Isn't removed in the current bug 648911 patch, so doing here instead.

Couldn't tell from comment 6 if the r+ was implicit or whether I needed to re-request, so though I should r? just in case.

Thanks!
Comment 10 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-05-11 10:02:15 PDT
Comment on attachment 531660 [details] [diff] [review]
Remove WinCE code from xpfe

It was implicit, but I'll put the stamps here anyways.
Comment 11 Ed Morley [:emorley] 2011-05-11 10:03:03 PDT
Thanks :-)
Comment 12 Daniel Holbert [:dholbert] 2011-05-12 10:58:35 PDT
http://hg.mozilla.org/projects/cedar/rev/13ad023ee970
Comment 13 Mounir Lamouri (:mounir) 2011-05-13 02:14:14 PDT
Pushed:
http://hg.mozilla.org/mozilla-central/rev/13ad023ee970

Note You need to log in before you can comment on or make changes to this bug.