Weird highlighting when adding text to an existing address

VERIFIED FIXED in Firefox 6

Status

()

Firefox
Location Bar
VERIFIED FIXED
6 years ago
4 years ago

People

(Reporter: tinagma, Assigned: Margaret)

Tracking

({polish})

Trunk
Firefox 6
polish
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox5 unaffected, firefox6-)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110504 Firefox/6.0a1
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110504 Firefox/6.0a1

When entering text into the location bar, the highlighting is weird, sometimes text entered is grey and sometimes not. It would be better if text stopped being highlighted when entering text.

Reproducible: Always

Steps to Reproduce:
1.go to any address (ex. google.com)
2.add some text to the address


Actual Results:  
text has many different highlights

Expected Results:  
text should change to be all one color when entered
(Reporter)

Comment 1

6 years ago
Created attachment 530033 [details]
screenshot of the weird highlighting
(Reporter)

Updated

6 years ago
Keywords: polish
Version: unspecified → Trunk

Comment 2

6 years ago
The highlighting is probably caused by:
Bug 451833 - Highlight the domain name in the address bar

But since you have entered an invalid URL the result may look strange.
Simpler STR:

1) Open www.google.com
2) After the page loads, start appending some characters to the url.
3) Weird highlighting occurs.

Marking as new.

The simple solution would be to just undo the domain highlighting (revert the url color) when the bar is hovered or clicked on.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 451833
I agree with Natch, it's kinda uncomfortable to edit light color text.
(Reporter)

Comment 5

6 years ago
yeah, comment 3 is what i meant to say, sorry.
status-firefox5: --- → unaffected
tracking-firefox6: --- → ?
(Assignee)

Comment 6

6 years ago
Created attachment 532002 [details] [diff] [review]
patch

This patch just removes the formatting when the location bar is focused, then adds it back on blur.
Assignee: nobody → margaret.leibovic
Status: NEW → ASSIGNED
Attachment #532002 - Flags: review?(dao)
Comment on attachment 532002 [details] [diff] [review]
patch

>+      <method name="clearFormatting">

_clearFormatting, since this is internal.
Attachment #532002 - Flags: review?(dao) → review+

Updated

6 years ago
OS: Windows XP → All
Hardware: x86 → All
(Assignee)

Comment 8

6 years ago
http://hg.mozilla.org/mozilla-central/rev/2601f4d06ffe
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 6

Comment 9

6 years ago
i reproduced this bug with these steps.

1. Open a web page in new tab, see that url is formatted.
2. Click url bar to clear formatting and add some text to the end of the url.
3. open new tab and focus there.
4. Click to the tab you created in step 1 .
5. Cursor is on the url-bar again and url is formatted
6. Try to add some text again, you will see weird highlighting again.
I can still see this on:
Mozilla/5.0 (Windows NT 6.1; rv:6.0a1) Gecko/20110515 Firefox/6.0a1

Can anyone else see this??

Should i REOPEN or file a new bug?

Comment 11

6 years ago
I can also still reproduce this.
Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110515 Firefox/6.0a1

I followed the STR in comment 9. Step 2 works fine now, but step 6 still creates weird highlighting.

Updated

6 years ago
Depends on: 657173

Comment 12

6 years ago
Bug 657173 addresses the issues in comment 9 and has been checked in today, so we should wait another day and test again before opening a new bug.

Comment 13

6 years ago
The issue is still reproducible on:
Mozilla/5.0 (Windows NT 6.1; rv:6.0a1) Gecko/20110519 Firefox/6.0a1

*Notes:
Following the STRs in Comment 9 reveals the weird highlighting as in the attachment/screenshot.
It is unclear if this bug is FIXED or not.

Comment 14

6 years ago
STR in comment 9 shows no weird highlighting for me any more.
Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110517 Firefox/6.0a1
Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110519 Firefox/6.0a1
Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110520 Firefox/6.0a1

Thus, I'm not able to fool the highlighter by doing the switch-to-another-tab trick, so to me it looks FIXED at least for Linux.

BTW, I can still reproduce the bug using the STR in comment 9 with:
Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110516 Firefox/6.0a1
tracking-firefox6: ? → -

Comment 15

6 years ago
tracking the implementation bug. no need to track this fixed regression.

Comment 16

6 years ago
Mozilla/5.0 (X11; Linux i686; rv:7.0a1) Gecko/20110629 Firefox/7.0a1

Verified issue on Ubuntu 11.04, Mac OS X 10.6, WinXP, Win7 using steps from Comment 9 and I am unable to reproduce the problem.

Setting status to Verified Fixed.
Status: RESOLVED → VERIFIED

Updated

5 years ago
Depends on: 814786
You need to log in before you can comment on or make changes to this bug.