Last Comment Bug 654729 - Weird highlighting when adding text to an existing address
: Weird highlighting when adding text to an existing address
Status: VERIFIED FIXED
: polish
Product: Firefox
Classification: Client Software
Component: Location Bar (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 6
Assigned To: :Margaret Leibovic
:
: Marco Bonardo [::mak]
Mentors:
Depends on: 657173 814786
Blocks: 451833
  Show dependency treegraph
 
Reported: 2011-05-04 09:04 PDT by tinagma
Modified: 2013-12-27 14:36 PST (History)
19 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
-


Attachments
screenshot of the weird highlighting (6.39 KB, image/png)
2011-05-04 09:05 PDT, tinagma
no flags Details
patch (2.65 KB, patch)
2011-05-12 12:06 PDT, :Margaret Leibovic
dao+bmo: review+
Details | Diff | Splinter Review

Description tinagma 2011-05-04 09:04:08 PDT
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110504 Firefox/6.0a1
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110504 Firefox/6.0a1

When entering text into the location bar, the highlighting is weird, sometimes text entered is grey and sometimes not. It would be better if text stopped being highlighted when entering text.

Reproducible: Always

Steps to Reproduce:
1.go to any address (ex. google.com)
2.add some text to the address


Actual Results:  
text has many different highlights

Expected Results:  
text should change to be all one color when entered
Comment 1 tinagma 2011-05-04 09:05:27 PDT
Created attachment 530033 [details]
screenshot of the weird highlighting
Comment 2 Thomas Ahlblom 2011-05-04 12:45:09 PDT
The highlighting is probably caused by:
Bug 451833 - Highlight the domain name in the address bar

But since you have entered an invalid URL the result may look strange.
Comment 3 Nochum Sossonko [:Natch] 2011-05-04 13:39:26 PDT
Simpler STR:

1) Open www.google.com
2) After the page loads, start appending some characters to the url.
3) Weird highlighting occurs.

Marking as new.

The simple solution would be to just undo the domain highlighting (revert the url color) when the bar is hovered or clicked on.
Comment 4 Csaba Kozák [:WonderCsabo] 2011-05-04 13:43:26 PDT
I agree with Natch, it's kinda uncomfortable to edit light color text.
Comment 5 tinagma 2011-05-04 18:15:48 PDT
yeah, comment 3 is what i meant to say, sorry.
Comment 6 :Margaret Leibovic 2011-05-12 12:06:51 PDT
Created attachment 532002 [details] [diff] [review]
patch

This patch just removes the formatting when the location bar is focused, then adds it back on blur.
Comment 7 Dão Gottwald [:dao] 2011-05-12 12:48:12 PDT
Comment on attachment 532002 [details] [diff] [review]
patch

>+      <method name="clearFormatting">

_clearFormatting, since this is internal.
Comment 8 :Margaret Leibovic 2011-05-12 14:44:47 PDT
http://hg.mozilla.org/mozilla-central/rev/2601f4d06ffe
Comment 9 Can 2011-05-12 21:58:37 PDT
i reproduced this bug with these steps.

1. Open a web page in new tab, see that url is formatted.
2. Click url bar to clear formatting and add some text to the end of the url.
3. open new tab and focus there.
4. Click to the tab you created in step 1 .
5. Cursor is on the url-bar again and url is formatted
6. Try to add some text again, you will see weird highlighting again.
Comment 10 Simona B [:simonab ] 2011-05-16 01:15:52 PDT
I can still see this on:
Mozilla/5.0 (Windows NT 6.1; rv:6.0a1) Gecko/20110515 Firefox/6.0a1

Can anyone else see this??

Should i REOPEN or file a new bug?
Comment 11 Thomas Ahlblom 2011-05-16 04:10:32 PDT
I can also still reproduce this.
Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110515 Firefox/6.0a1

I followed the STR in comment 9. Step 2 works fine now, but step 6 still creates weird highlighting.
Comment 12 Thomas Ahlblom 2011-05-16 05:55:07 PDT
Bug 657173 addresses the issues in comment 9 and has been checked in today, so we should wait another day and test again before opening a new bug.
Comment 13 AndreiD[QA] 2011-05-20 05:37:23 PDT
The issue is still reproducible on:
Mozilla/5.0 (Windows NT 6.1; rv:6.0a1) Gecko/20110519 Firefox/6.0a1

*Notes:
Following the STRs in Comment 9 reveals the weird highlighting as in the attachment/screenshot.
It is unclear if this bug is FIXED or not.
Comment 14 Thomas Ahlblom 2011-05-20 12:08:01 PDT
STR in comment 9 shows no weird highlighting for me any more.
Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110517 Firefox/6.0a1
Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110519 Firefox/6.0a1
Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110520 Firefox/6.0a1

Thus, I'm not able to fool the highlighter by doing the switch-to-another-tab trick, so to me it looks FIXED at least for Linux.

BTW, I can still reproduce the bug using the STR in comment 9 with:
Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110516 Firefox/6.0a1
Comment 15 Asa Dotzler [:asa] 2011-05-24 14:47:24 PDT
tracking the implementation bug. no need to track this fixed regression.
Comment 16 George Carstoiu 2011-06-29 07:31:06 PDT
Mozilla/5.0 (X11; Linux i686; rv:7.0a1) Gecko/20110629 Firefox/7.0a1

Verified issue on Ubuntu 11.04, Mac OS X 10.6, WinXP, Win7 using steps from Comment 9 and I am unable to reproduce the problem.

Setting status to Verified Fixed.

Note You need to log in before you can comment on or make changes to this bug.