Focusing an element inside the location bar (e.g. notification icons, identity icon) removes domain highlighting

RESOLVED FIXED in Firefox 42

Status

()

Firefox
Address Bar
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: M8R-p7, Unassigned)

Tracking

({regression})

6 Branch
Firefox 42
regression
Points:
2
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed by bug 834830)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20.0 Firefox/20.0
Build ID: 20121121030712

Steps to reproduce:

Visit a site that will prompt you with a Notification icon in the URLbar. The plugins.click_to_play feature gives the cleanest examples, as it presents no messages until clicked.


Actual results:

Clicking the Notification icon in the URLbar removes domain highlighting from the current URL. It is not reinstated once the notification has been closed.


Expected results:

Domain highlighting should be unaffected.

Comment 1

6 years ago
I can reproduce
http://hg.mozilla.org/mozilla-central/rev/d8e4f06198dc
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20.0 Firefox/20.0 ID:20121123030827
Status: UNCONFIRMED → NEW
Component: Untriaged → Location Bar
Ever confirmed: true

Comment 2

6 years ago
Clicking password-notification-icon also removes the domain highlight.

Comment 3

6 years ago
Regression window
Good:
http://hg.mozilla.org/mozilla-central/rev/43949eb48546
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110512 Firefox/6.0a1 ID:20110512101326
Bad:
http://hg.mozilla.org/mozilla-central/rev/2601f4d06ffe
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110512 Firefox/6.0a1 ID:20110512144531
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=43949eb48546&tochange=2601f4d06ffe

Regressed by: Bug 654729
Blocks: 654729
Keywords: regression

Comment 4

6 years ago
WORKAROUND:

#notification-popup-box *{
-moz-user-focus:ignore  !important;
}

Comment 5

6 years ago
(In reply to Alice0775 White from comment #4)
> WORKAROUND:
> 
> #notification-popup-box *{
> -moz-user-focus:ignore  !important;
> }

Aha,this workaround breaks tab key navigation(Bug 572967).

Updated

6 years ago
Version: 17 Branch → 6 Branch
Created attachment 684967 [details] [diff] [review]
patch
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #684967 - Flags: review?(bmcbride)

Updated

6 years ago
Duplicate of this bug: 814850

Updated

6 years ago
OS: Windows 7 → All
Hardware: x86_64 → All

Updated

6 years ago
Summary: Clicking a Notification Icon removes Domain Highlighting → Focusing an element inside the location bar (e.g. notification icons, identity icon) removes domain highlighting
Comment on attachment 684967 [details] [diff] [review]
patch

Review of attachment 684967 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, but it really needs a test.
Attachment #684967 - Flags: review?(bmcbride) → review-

Updated

6 years ago
Assignee: dao → nobody
Status: ASSIGNED → NEW

Updated

4 years ago
Whiteboard: p=0

Updated

4 years ago
No longer blocks: 950073
Flags: firefox-backlog+
Whiteboard: p=0 → p=2 [qa?]

Updated

4 years ago
Points: --- → 2
Flags: qe-verify?
Whiteboard: p=2 [qa?]

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Depends on: 834830
Resolution: --- → FIXED
Whiteboard: fixed by bug 834830
Target Milestone: --- → Firefox 42
You need to log in before you can comment on or make changes to this bug.