Last Comment Bug 654741 - Notify Fennec chrome of window.scrollTo/scrollBy even when scroll position does not change
: Notify Fennec chrome of window.scrollTo/scrollBy even when scroll position do...
Status: RESOLVED FIXED
: compat, mobile, testcase
Product: Core
Classification: Components
Component: DOM: Events (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks: 616348 653956 654122
  Show dependency treegraph
 
Reported: 2011-05-04 09:30 PDT by Matt Brubeck (:mbrubeck)
Modified: 2012-06-14 12:48 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+


Attachments
test case: onload="scrollTo(0,-1)" (276 bytes, text/html)
2011-05-04 09:30 PDT, Matt Brubeck (:mbrubeck)
no flags Details

Description Matt Brubeck (:mbrubeck) 2011-05-04 09:30:24 PDT
Created attachment 530043 [details]
test case: onload="scrollTo(0,-1)"

When content calls window.scrollTo/scrollBy in Fennec, we would like to hide the Fennec chrome.  This is useful for pages like Google Maps which use this to hide the titlebar and sidebars on page load (see bug 653956).

In the default Android and iOS browsers, calling scrollTo causes the browser chrome to scroll out of view even if it does not change the content scroll position.  For example, the attached test case calls scrollTo(0,-1) on load, and it hides the browser chrome in the Android Browser but not in Fennec.

nsGfxScrollFrameInner::ScrollToImpl suppresses all events and notifications if the new location is the same as the old one.  We would need some sort of notification that still fires in this case.  I hope we can do this without a noticeable performance impact from too many messages:
http://mxr.mozilla.org/mozilla-central/source/layout/generic/nsGfxScrollFrame.cpp#1828
Comment 1 Matt Brubeck (:mbrubeck) 2011-05-04 09:33:34 PDT
Nominating for tracking-fennec because it would improve usability on popular pages like Google Maps.
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2011-07-15 08:22:50 PDT
Still tracking, but it won't make fx7, let alone fx6, unless some work starts soon.
Comment 3 Aaron Train [:aaronmt] 2012-05-24 11:08:07 PDT
Is this still an issue on Fennec Native? Does it still block 616348?
Comment 4 Lawrence Mandel [:lmandel] (use needinfo) 2012-06-05 12:04:07 PDT
(In reply to Aaron Train [:aaronmt] from comment #3)
> Is this still an issue on Fennec Native? Does it still block 616348?

Mark/Matt - Can one of you please comment to answer Aaron's question.
Comment 5 Kevin Brosnan [:kbrosnan] 2012-06-14 12:48:18 PDT
Mat we believe that this was fixed by the native rewrite. Reopen if this is still an issue.

Note You need to log in before you can comment on or make changes to this bug.