Last Comment Bug 655010 - Remove WinCE code from Mozilla owned parts of ImageLib
: Remove WinCE code from Mozilla owned parts of ImageLib
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: Trunk
: All Windows CE
: -- normal (vote)
: mozilla6
Assigned To: Ed Morley [:emorley]
:
Mentors:
Depends on:
Blocks: 614720
  Show dependency treegraph
 
Reported: 2011-05-05 07:20 PDT by Ed Morley [:emorley]
Modified: 2011-05-06 19:16 PDT (History)
1 user (show)
bzbarsky: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove WinCE code from mozilla owned parts of ImageLib (4.89 KB, patch)
2011-05-05 08:07 PDT, Ed Morley [:emorley]
joe: review+
Details | Diff | Review

Description Ed Morley [:emorley] 2011-05-05 07:20:47 PDT
WinCE & Windows Mobile code is being slowly removed by bug 614720 - since it's broken, no longer supported, and only serves to complicate code maintenance. 

This bug is for the:

- modules/zlib/*
http://mxr.mozilla.org/mozilla-central/search?string=wince&find=/modules/zlib/
http://mxr.mozilla.org/mozilla-central/search?string=win32_wce&find=/modules/zlib/

- modules/libpr0n/*
http://mxr.mozilla.org/mozilla-central/search?string=wince&find=/modules/libpr0n/

- modules/libimg/* 
http://mxr.mozilla.org/mozilla-central/search?string=wince&find=/modules/libimg/
http://mxr.mozilla.org/mozilla-central/search?string=win32_wce&find=/modules/libimg/

...parts of the removal.
Comment 1 Ed Morley [:emorley] 2011-05-05 08:03:24 PDT
Sorry for the accidental CC Joe; was using the CC field to lookup your email for the review & forgot to remove the text before adjusting the bug title.
Comment 2 Ed Morley [:emorley] 2011-05-05 08:07:06 PDT
Created attachment 530314 [details] [diff] [review]
Remove WinCE code from mozilla owned parts of ImageLib

Removes WinCE code from modules/libpr0n/* & modules/zlib/src/Makefile.in

Does not touch modules/libimg/* or anything in zlib apart from the Makefile, since from upstream (comment 0 was before I realised this).
Comment 3 Ed Morley [:emorley] 2011-05-05 13:11:13 PDT
Thanks Joe :-)
Comment 4 Ed Morley [:emorley] 2011-05-05 15:12:54 PDT
http://dev.philringnalda.com/tbpl/?tree=Try&rev=c49489125caa
Comment 5 Boris Zbarsky [:bz] 2011-05-05 19:58:05 PDT
http://hg.mozilla.org/projects/cedar/rev/8056d9a01d44
Comment 6 Ed Morley [:emorley] 2011-05-06 19:16:43 PDT
http://hg.mozilla.org/mozilla-central/rev/8056d9a01d44

Note You need to log in before you can comment on or make changes to this bug.