Last Comment Bug 655176 - Remove WinCE code from docshell
: Remove WinCE code from docshell
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Document Navigation (show other bugs)
: Trunk
: All Windows CE
: -- normal (vote)
: mozilla6
Assigned To: Ed Morley [:emorley]
:
Mentors:
Depends on:
Blocks: 614720
  Show dependency treegraph
 
Reported: 2011-05-05 17:09 PDT by Ed Morley [:emorley]
Modified: 2011-10-20 22:40 PDT (History)
4 users (show)
jruderman: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove WinCE code from docshell (incl broken uriloader/exthandler/Makefile.in WINNT |ifeq|s) (4.96 KB, patch)
2011-05-06 05:57 PDT, Ed Morley [:emorley]
bzbarsky: review+
Details | Diff | Review

Description Ed Morley [:emorley] 2011-05-05 17:09:24 PDT
WinCE & Windows Mobile code is being removed by bug 614720 - since it's broken, no longer supported, and only serves to complicate code maintenance. 

This bug is for the /docshell/* & /uriloader/* parts of the removal:

http://mxr.mozilla.org/mozilla-central/search?string=wince&find=/docshell/

http://mxr.mozilla.org/mozilla-central/search?string=wince&find=/uriloader/
Comment 1 Ed Morley [:emorley] 2011-05-05 17:37:33 PDT
In creating the patch for this, I've come across:
> ifeq ($(OS_ARCH),WINNT WINCE)

Here:
http://mxr.mozilla.org/mozilla-central/source/uriloader/exthandler/Makefile.in#183
and
http://mxr.mozilla.org/mozilla-central/source/uriloader/exthandler/Makefile.in#208

...which looks broken to me.

However, if I go ahead and remove the WINCE string, that segment of code will now run under WINNT when it didn't before. 

Should I:
a) Remove the segment entirely, since it isn't being run at present.
b) Remove the WINCE string, thereby fixing that segment for WINNT and hope it's still needed?

Those lines were added back in CVS, with CVS blame saying:
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=Makefile.in&branch=1.61&root=/cvsroot&subdir=mozilla/uriloader/exthandler&command=DIFF_FRAMESET&rev1=1.60&rev2=1.61
...however there is no bug number mentioned in the commit message.
Comment 2 Ted Mielczarek [:ted.mielczarek] 2011-05-06 05:22:41 PDT
Classic. dougt landed a broken fix with r=dougt. :)

Honestly, I would just remove those sections since they haven't done anything useful in the past 6 years and nobody has noticed. The crud about cygwin make is outdated, we no longer support cygwin as a build environment.
Comment 3 Ed Morley [:emorley] 2011-05-06 05:57:21 PDT
Created attachment 530602 [details] [diff] [review]
Remove WinCE code from docshell (incl broken uriloader/exthandler/Makefile.in WINNT |ifeq|s)

Thanks Ted, have removed those sections entirely.

http://dev.philringnalda.com/tbpl/?tree=Try&rev=4a6a7b83227b
Comment 4 Boris Zbarsky [:bz] 2011-05-06 09:13:19 PDT
Comment on attachment 530602 [details] [diff] [review]
Remove WinCE code from docshell (incl broken uriloader/exthandler/Makefile.in WINNT |ifeq|s)

r=me
Comment 5 Daniel Holbert [:dholbert] 2011-05-06 11:46:33 PDT
http://hg.mozilla.org/mozilla-central/rev/f20bf706d0b5

Note You need to log in before you can comment on or make changes to this bug.