Last Comment Bug 655197 - Win7 debug intermittent but very frequent browser_tabview_bug597248.js | All tabs were saved when window was closed. - Got 3, expected 0 followed by Test timed out
: Win7 debug intermittent but very frequent browser_tabview_bug597248.js | All ...
Status: RESOLVED FIXED
: intermittent-failure
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: Trunk
: x86 Windows 7
: -- major
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 655269
Blocks: 438871 595020
  Show dependency treegraph
 
Reported: 2011-05-05 20:26 PDT by Phil Ringnalda (:philor, back in August)
Modified: 2016-04-12 14:00 PDT (History)
1 user (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Phil Ringnalda (:philor, back in August) 2011-05-05 20:26:25 PDT
Pending further retests on earlier pushes, this appears to have started on Cedar with (with some of the normal console-spam trimmed):

http://tinderbox.mozilla.org/showlog.cgi?log=Cedar/1304624118.1304629067.7672.gz&fulltext=1#err2
Rev3 WINNT 6.1 cedar debug test mochitest-other on 2011/05/05 12:35:18
s: talos-r3-w7-030

TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | There should be 3 tab items before closing
JavaScript error: , line 0: uncaught exception: [Exception... "'Illegal value' when calling method: [nsISessionStore::setWindowValue]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://browser/content/tabview.js :: Storage_saveActiveGroupName :: line 1210"  data: no]
WARNING: getting z level of unregistered window: file e:/builds/moz2_slave/ced-w32-dbg/build/xpfe/appshell/src/nsWindowMediator.cpp, line 600
WARNING: getting z level of unregistered window: file e:/builds/moz2_slave/ced-w32-dbg/build/xpfe/appshell/src/nsWindowMediator.cpp, line 600
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file e:/builds/moz2_slave/ced-w32-dbg/build/content/base/src/nsContentUtils.cpp, line 2937
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file e:/builds/moz2_slave/ced-w32-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 327
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file e:/builds/moz2_slave/ced-w32-dbg/build/content/base/src/nsContentUtils.cpp, line 2937
(more of that usual spam)
WARNING: NS_ENSURE_TRUE(doc) failed: file e:/builds/moz2_slave/ced-w32-dbg/build/layout/forms/nsTextControlFrame.cpp, line 339
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file e:/builds/moz2_slave/ced-w32-dbg/build/layout/forms/nsTextControlFrame.cpp, line 1106
TEST-INFO | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | Console message: [JavaScript Error: "uncaught exception: [Exception... "'Illegal value' when calling method: [nsISessionStore::setWindowValue]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://browser/content/tabview.js :: Storage_saveActiveGroupName :: line 1210"  data: no]"]
pldhash: for the table at address 1636BF20, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 1636BEB8 == 18
++DOMWINDOW == 86 (16481280) [serial = 1433] [outer = 00000000]
WARNING: Subdocument container has no content: file e:/builds/moz2_slave/ced-w32-dbg/build/layout/base/nsDocumentViewer.cpp, line 2380
++DOMWINDOW == 87 (16481468) [serial = 1434] [outer = 16481230]
WARNING: Subdocument container has no content: file e:/builds/moz2_slave/ced-w32-dbg/build/layout/base/nsDocumentViewer.cpp, line 2380
window moved to offscreen position
JavaScript strict warning: chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js, line 52: assignment to undeclared variable restoredWin
(some GC)
WARNING: Subdocument container has no content: file e:/builds/moz2_slave/ced-w32-dbg/build/layout/base/nsDocumentViewer.cpp, line 2380
TEST-INFO | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | Console message: [JavaScript Warning: "assignment to undeclared variable restoredWin" {file: "chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js" line: 52}]
(some GC)
TEST-INFO | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | Console message: [JavaScript Warning: "XUL box for _moz_generated_content_after element contained an inline #text child, forcing all its children to be wrapped in a block." {file: "chrome://browser/content/browser.xul" line: 0}]
WARNING: Subdocument container has no frame: file e:/builds/moz2_slave/ced-w32-dbg/build/layout/base/nsDocumentViewer.cpp, line 2400
++DOMWINDOW == 77 (16C27DE8) [serial = 1439] [outer = 164F0348]
WARNING: Subdocument container has no frame: file e:/builds/moz2_slave/ced-w32-dbg/build/layout/base/nsDocumentViewer.cpp, line 2400
++DOMWINDOW == 78 (16C27C00) [serial = 1440] [outer = 164EFBA8]
++DOMWINDOW == 79 (1695EA40) [serial = 1441] [outer = 14D587D8]
pldhash: for the table at address 18AD3328, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 18AD32C0 == 14
++DOMWINDOW == 80 (1695D5F8) [serial = 1442] [outer = 00000000]
++DOMWINDOW == 81 (1695CCC0) [serial = 1443] [outer = 1695D5A8]
pldhash: for the table at address 18AD10A8, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 18AD1040 == 15
++DOMWINDOW == 82 (1695C1B0) [serial = 1444] [outer = 00000000]
++DOMWINDOW == 83 (1695E868) [serial = 1445] [outer = 1695C160]
pldhash: for the table at address 18AD1720, the given entrySize of 48 probably favors chaining over double hashing.
++DOCSHELL 18AD16B8 == 16
++DOMWINDOW == 84 (16C26150) [serial = 1446] [outer = 00000000]
WARNING: NS_ENSURE_TRUE(aURI) failed: file e:/builds/moz2_slave/ced-w32-dbg/build/content/base/src/nsContentUtils.cpp, line 5045
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | All tabs were saved when window was closed. - Got 3, expected 0
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | The total number of tabs is 3
WARNING: No inner window available!: file e:/builds/moz2_slave/ced-w32-dbg/build/dom/base/nsGlobalWindow.cpp, line 7551
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | Tab item is showing cached data and is just connected. about:blank
TEST-INFO | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | Console message: Error while loading thumbnail
TEST-PASS | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | Tab item is showing cached data and is just connected. http://mochi.test:8888/browser/browser/base/content/test/tabview/dummy_page.html
(more GC)
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | Test timed out
Comment 2 Treeherder Robot 2011-05-05 20:32:38 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1304635393.1304640515.1585.gz
Rev3 WINNT 6.1 mozilla-central debug test mochitest-other on 2011/05/05 15:43:13

s: talos-r3-w7-027
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | All tabs were saved when window was closed. - Got 3, expected 0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | Test timed out
Comment 3 Treeherder Robot 2011-05-05 20:33:04 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1304643072.1304647952.6569.gz
Rev3 WINNT 6.1 mozilla-central debug test mochitest-other on 2011/05/05 17:51:12

s: talos-r3-w7-036
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | All tabs were saved when window was closed. - Got 3, expected 0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | Test timed out
Comment 4 Treeherder Robot 2011-05-05 20:42:17 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1304648357.1304653100.28835.gz
Rev3 WINNT 6.1 mozilla-central debug test mochitest-other on 2011/05/05 19:19:17

s: talos-r3-w7-006
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | All tabs were saved when window was closed. - Got 3, expected 0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | Test timed out
Comment 5 Treeherder Robot 2011-05-05 20:55:58 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1304648614.1304653378.30031.gz
Rev3 WINNT 6.1 mozilla-central debug test mochitest-other on 2011/05/05 19:23:34

s: talos-r3-w7-043
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | All tabs were saved when window was closed. - Got 3, expected 0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | Test timed out
Comment 6 Treeherder Robot 2011-05-05 21:16:27 PDT
philor
http://tinderbox.mozilla.org/showlog.cgi?log=Cedar/1304650276.1304655053.4620.gz
Rev3 WINNT 6.1 cedar debug test mochitest-other on 2011/05/05 19:51:16

s: talos-r3-w7-041
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | All tabs were saved when window was closed. - Got 3, expected 0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | Test timed out
Comment 7 Treeherder Robot 2011-05-06 00:34:17 PDT
ewong
http://tinderbox.mozilla.org/showlog.cgi?log=Try/1304660425.1304665216.14235.gz
Rev3 WINNT 6.1 try debug test mochitest-other on 2011/05/05 22:40:25

s: talos-r3-w7-019
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | All tabs were saved when window was closed. - Got 3, expected 0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | Test timed out
Comment 8 Treeherder Robot 2011-05-06 05:53:52 PDT
mounir
http://tinderbox.mozilla.org/showlog.cgi?log=Cedar/1304680541.1304685372.22022.gz
Rev3 WINNT 6.1 cedar debug test mochitest-other on 2011/05/06 04:15:41

s: talos-r3-w7-011
PROCESS-CRASH | Main app process exited normally | application crashed (minidump found)
Thread 0 (crashed)
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | All tabs were saved when window was closed. - Got 3, expected 0
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/base/content/test/tabview/browser_tabview_bug597248.js | Test timed out
Comment 9 Boris Zbarsky [:bz] 2011-05-06 08:57:41 PDT
We believe this was caused by bug 595020, which has now been backed out to fix the problem.

Note You need to log in before you can comment on or make changes to this bug.