Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Uninitialized memory used in nsTextFrame::AddInlineMinWidthForFlow with -moz-hyphen

RESOLVED FIXED

Status

()

Core
Layout: Text
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Jesse Ruderman, Assigned: jfkthame)

Tracking

(Blocks: 1 bug, {testcase, valgrind})

Trunk
x86_64
Linux
testcase, valgrind
Points:
---

Firefox Tracking Flags

(firefox6-)

Details

(Whiteboard: [sg:low?])

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 530550 [details]
testcase
(Reporter)

Comment 1

6 years ago
Created attachment 530551 [details]
valgrind output (firefox debug)
(Assignee)

Comment 2

6 years ago
Created attachment 530817 [details] [diff] [review]
patch, avoid looking one position beyond the actual length of hyphBreakBefore[]
Assignee: nobody → jfkthame
Attachment #530817 - Flags: review?(roc)
tracking-firefox6: --- → ?
(Reporter)

Updated

6 years ago
Whiteboard: [sg:low?]
Comment on attachment 530817 [details] [diff] [review]
patch, avoid looking one position beyond the actual length of hyphBreakBefore[]

Review of attachment 530817 [details] [diff] [review]:
-----------------------------------------------------------------
Attachment #530817 - Flags: review?(roc) → review+
(Assignee)

Comment 4

6 years ago
http://hg.mozilla.org/mozilla-central/rev/dfcfa00eb188
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Duplicate of this bug: 658488
[in triage meeting] No longer need to track this since it's fixed; we just needed to make sure we got this in before we shipped -moz-hyphens.
tracking-firefox6: ? → -
You need to log in before you can comment on or make changes to this bug.