Closed Bug 655212 Opened 11 years ago Closed 11 years ago

Hyperlinks are non-active on tap at maps.google.com

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: anamaria.moldovan, Assigned: wesj)

References

Details

(Keywords: regression)

Attachments

(1 file)

Build Id: Mozilla /5.0 (Android;Linux armv7l;rv:6.0a1) Gecko/20110505 Firefox/6.0a1 Fennec/6.0a1 

Devices: HTC Desire Z (Android 2.2), LG Optimus 2x (Android 2.2)

Steps to reproduce:
1. Go to maps.google.com.
2. Tap on the third button from left to right to enter the classic mode.
3. A new webpage appears; at the bottom of the page one should see a "Classic" link. Tap on it.

Actual results: 
Nothing happens. The "Classic" link is highlighted but it triggers no action. See the attached screenshot.

Expected results:
When tapping the "Classic" link the user should be directed to the classic version of the web page. 

Note: It works fine on the Android Native Browser.
Actually none of those links are responding to a tap. If you tap and hold you can open them in a new tab.

This is a regression as they work normally in 4.0.1
Component: Extension Compatibility → General
QA Contact: extension-compatibility → general
Summary: Cannot get the classic version for maps.google.com → Hyperlinks are non-active on tap at maps.google.com
Whiteboard: regression
perhaps a regression from touch events landing?
Whiteboard: regression
Google is calling prevent default on the touch events we fire on the page, which according to the current spec, should also cancel the mouseclick. I wonder if we're hitting some difference between the Android default browser and the iOS one?
Blocks: 544614
tracking-fennec: --- → ?
breaks on 4/30 build, works on 4/29 build.

Mozilla/5.0 (Android; Linux armv71; rv6.0a1) Gecko/20110430 Firefox/6.0a1 Fennec/6.0a1
Device: Thunderbolt
OS: Android 2.2
tracking-fennec: ? → 6+
Blocks: 663335
Wes / Matt - what's the plan here? How critical is this bug? I assume it only affects touch event sites, but given that, how bad is it for such sites?
This will only affect sites the are calling preventDefault on touchEvents. I spent awhile a week ago trying various changes to our touch event code to see what it takes to make Google recognize the clicks here, with no success. I think I am going to have to take apart the page to make more progress.
I've dug into the js-source on maps today. It looks like Google intercepts the touch events and then refires mouse events on the document. If some set of conditions are met (its a single touch, only one finger has been active on the map, they haven't received any touchmove events, etc), they will fire a click.

All of this seems to work fine in a reduced test page for Fennec though. Still need to do more digging to see what's failing and whether its our fault or not.
No longer blocks: 663335
Blocks: 663335
Assigning to Wes so we don't let this drop off radar
Assignee: nobody → wjohnston
tracking-fennec: 6+ → 7+
This works for me on latest-Nightly (07/28) as well as latest-aurora (07/28). Close as WFM?
Yep
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Status: RESOLVED → VERIFIED
tracking-fennec: 7+ → ---
You need to log in before you can comment on or make changes to this bug.