Last Comment Bug 655427 - make sharedIDs used by automation not depend on package name
: make sharedIDs used by automation not depend on package name
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Widget: Android (show other bugs)
: Trunk
: All Android
: -- normal (vote)
: ---
Assigned To: Brad Lassey [:blassey] (use needinfo?)
:
Mentors:
Depends on:
Blocks: 654838
  Show dependency treegraph
 
Reported: 2011-05-06 18:29 PDT by Brad Lassey [:blassey] (use needinfo?)
Modified: 2011-06-11 04:34 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
patch (1.22 KB, patch)
2011-05-06 18:29 PDT, Brad Lassey [:blassey] (use needinfo?)
no flags Details | Diff | Splinter Review
alternate patch (3.90 KB, patch)
2011-05-06 18:46 PDT, Matt Brubeck (:mbrubeck)
no flags Details | Diff | Splinter Review
alternate patch (4.69 KB, patch)
2011-05-06 18:49 PDT, Matt Brubeck (:mbrubeck)
no flags Details | Diff | Splinter Review
patch (1.69 KB, patch)
2011-05-06 18:58 PDT, Brad Lassey [:blassey] (use needinfo?)
mark.finkle: review+
mark.finkle: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Brad Lassey [:blassey] (use needinfo?) 2011-05-06 18:29:40 PDT
Created attachment 530784 [details] [diff] [review]
patch
Comment 1 Matt Brubeck (:mbrubeck) 2011-05-06 18:46:01 PDT
Created attachment 530786 [details] [diff] [review]
alternate patch

This patch is slightly bigger, but has the advantage that it does the right thing if anyone ever builds a non-Fennec Android app on the Mozilla platform.  (Same as attachment 530783 [details] [diff] [review] from bug 654838, but updated to include Aurora.)

I'd be fine either way on this, since non-Fennec Android apps are purely theoretical at this point.
Comment 2 Matt Brubeck (:mbrubeck) 2011-05-06 18:49:06 PDT
Created attachment 530787 [details] [diff] [review]
alternate patch

added a missing bit
Comment 3 Brad Lassey [:blassey] (use needinfo?) 2011-05-06 18:58:57 PDT
Created attachment 530788 [details] [diff] [review]
patch

this keeps the existing behavior for any app other than fennec
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2011-05-06 20:40:12 PDT
Comment on attachment 530788 [details] [diff] [review]
patch


>diff --git a/embedding/android/Makefile.in b/embedding/android/Makefile.in
>   -DANDROID_VERSION_CODE=$(ANDROID_VERSION_CODE) \
>   $(NULL)
> 
>+
>+
>+
> GARBAGE += \

No need to add the extra line breaks

r+ with the nit

Note You need to log in before you can comment on or make changes to this bug.