Last Comment Bug 655488 - Remove WinCE code from RDF
: Remove WinCE code from RDF
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: RDF (show other bugs)
: Trunk
: All Windows CE
: -- normal (vote)
: mozilla6
Assigned To: Ed Morley [:emorley]
:
:
Mentors:
Depends on:
Blocks: 614720
  Show dependency treegraph
 
Reported: 2011-05-07 08:27 PDT by Ed Morley [:emorley]
Modified: 2011-05-13 02:14 PDT (History)
3 users (show)
mounir: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove WinCE code from RDF (1.31 KB, patch)
2011-05-07 08:30 PDT, Ed Morley [:emorley]
axel: review+
Details | Diff | Splinter Review
Remove WinCE code from RDF (1.29 KB, patch)
2011-05-11 08:46 PDT, Ed Morley [:emorley]
emorley: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2011-05-07 08:27:07 PDT
WinCE & Windows Mobile code is being removed by bug 614720 - since it's broken, no longer supported, and only serves to complicate code maintenance. 

This bug is for the rdf/* parts of the removal:
http://mxr.mozilla.org/mozilla-central/search?string=wince&find=/rdf/
Comment 1 Ed Morley [:emorley] 2011-05-07 08:30:54 PDT
Created attachment 530840 [details] [diff] [review]
Remove WinCE code from RDF
Comment 2 Ed Morley [:emorley] 2011-05-08 06:41:14 PDT
Not exactly a risky patch, but I was submitting a try run anyway:
http://dev.philringnalda.com/tbpl/?tree=Try&rev=f88432556f2e
Comment 3 Axel Hecht 2011-05-11 08:00:28 PDT
Comment on attachment 530840 [details] [diff] [review]
Remove WinCE code from RDF

r=me with a nit, make
#if defined (XP_WIN)

#ifdef XP_WIN

same for the XP_UNIX. That's more in line with how the rest of the file is.
Comment 4 Ed Morley [:emorley] 2011-05-11 08:46:22 PDT
Created attachment 531644 [details] [diff] [review]
Remove WinCE code from RDF

Updated for nits in comment 3.
Carrying forwards r+
Comment 5 Daniel Holbert [:dholbert] 2011-05-12 10:59:03 PDT
http://hg.mozilla.org/projects/cedar/rev/05379695923c
Comment 6 Mounir Lamouri (:mounir) 2011-05-13 02:14:33 PDT
Pushed:
http://hg.mozilla.org/mozilla-central/rev/05379695923c

Note You need to log in before you can comment on or make changes to this bug.