Last Comment Bug 655493 - Remove WinCE code from layout
: Remove WinCE code from layout
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All Windows CE
: -- normal (vote)
: mozilla6
Assigned To: Ed Morley [:emorley]
:
:
Mentors:
Depends on:
Blocks: 614720
  Show dependency treegraph
 
Reported: 2011-05-07 08:58 PDT by Ed Morley [:emorley]
Modified: 2011-05-09 10:20 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove WinCE code from layout/base/tests/TestPoisonArea.cpp (1.57 KB, patch)
2011-05-07 09:03 PDT, Ed Morley [:emorley]
roc: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2011-05-07 08:58:25 PDT
WinCE & Windows Mobile code is being removed by bug 614720 - since it's broken, no longer supported, and only serves to complicate code maintenance. 

This bug is for the layout/* parts of the removal:
http://mxr.mozilla.org/mozilla-central/search?string=wince&find=/layout/
Comment 1 Ed Morley [:emorley] 2011-05-07 09:03:00 PDT
Created attachment 530843 [details] [diff] [review]
Remove WinCE code from layout/base/tests/TestPoisonArea.cpp

The only other remaining WinCE reference in layout is here:
http://mxr.mozilla.org/mozilla-central/source/layout/style/nsCSSScanner.cpp#1309

Are there any other platforms that need pow() rather than powf()? If not, would it be desirable to change this to powf() now?
Comment 2 Ed Morley [:emorley] 2011-05-08 06:41:34 PDT
Not exactly a risky patch, but I was submitting a try run anyway:
http://dev.philringnalda.com/tbpl/?tree=Try&rev=f88432556f2e
Comment 3 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-05-09 02:34:12 PDT
Comment on attachment 530843 [details] [diff] [review]
Remove WinCE code from layout/base/tests/TestPoisonArea.cpp

Review of attachment 530843 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 4 Matt Brubeck (:mbrubeck) 2011-05-09 10:20:41 PDT
http://hg.mozilla.org/mozilla-central/rev/052bbd46f96f

Note You need to log in before you can comment on or make changes to this bug.