The Aurora channel gives links to central because app.update.url.manual is http://nightly.mozilla.org

VERIFIED FIXED in Firefox 8

Status

()

Firefox
Preferences
--
major
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: Pedro Bessa, Assigned: Anders G. Jørgensen)

Tracking

({verified-aurora})

Trunk
Firefox 8
verified-aurora
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug][inbound][qa!])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:5.0a2) Gecko/20110504 Firefox/5.0a2
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:5.0a2) Gecko/20110504 Firefox/5.0a2

I have firefox 5 aurora, I'm in the aurora update channel, but aurora shows me firefox 6 alpha 1 which is a central, nightly firefox.

the link is to http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/firefox-6.0a1.en-US.linux-i686.tar.bz2

Reproducible: Always

Steps to Reproduce:
1. Open Aurora
2. Help
3. About Aurora

Actual Results:  
update available in http://*nightly*.mozilla.org/
you're currently on the *aurora update channel*

Expected Results:  
no centrals, nightlies to me, when the team that makes firefox 5 aurora moves to firefox 6 aurora, I'll use firefox 6 aurora
(Reporter)

Comment 1

6 years ago
more steps:
4. click http://*nightly*.mozilla.org/
5. click Linux
6. click Intel

more actual results:
the link is to a central

more expected results:
the link is to an aurora
app.update.url.manual does indeed take users to http://nightly.mozilla.org:

http://hg.mozilla.org/releases/mozilla-aurora/file/tip/browser/branding/aurora/pref/firefox-branding.js#l12
Component: General → Preferences
OS: Linux → All
QA Contact: general → preferences
Hardware: x86 → All
Version: unspecified → 5 Branch
Duplicate of this bug: 666300

Updated

6 years ago
Duplicate of this bug: 666515

Updated

6 years ago
Duplicate of this bug: 666601

Comment 6

6 years ago
Considering comment 2 I will make this bug NEW and also I also add the [good first bug] from bug 666300.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [good first bug]

Updated

6 years ago
Summary: aurora channel gives me link to central → The Aurora channel gives links to central because app.update.url.manual is http://nightly.mozilla.org
(Assignee)

Comment 7

6 years ago
Created attachment 541820 [details] [diff] [review]
This should do it

This is my first patch for Firefox. I changed http://nightly.mozilla.org/ to http://www.mozilla.com/firefox/channel/. Or is there a more specific page about Aurora?
(Reporter)

Comment 8

6 years ago
http://www.mozilla.com/en-US/firefox/all-aurora.html
(Assignee)

Updated

6 years ago
Attachment #541820 - Flags: review?(dolske)

Comment 9

6 years ago
I don't believe that the dialog should use a preference.  Suppose I use Aurora for now.  But I then switch that profile to the 6.0 beta.  Now should the dialog continue to use a link for Aurora?  I don't think so.  It should provide a link for the beta.
Comment on attachment 541820 [details] [diff] [review]
This should do it

Thanks for the patch! This looks fine.
Attachment #541820 - Flags: review?(dolske) → review+
(In reply to comment #9)
> I don't believe that the dialog should use a preference.  Suppose I use
> Aurora for now.  But I then switch that profile to the 6.0 beta.

These are the _default_ prefs, which are included in the app. So if you switch from Aurora to Beta, the default pref value will change as well. This pattern is used extensively throughout Firefox branding.
Keywords: checkin-needed
Assignee: nobody → spirit55555
Pushed to mozilla-inbound:
 http://hg.mozilla.org/integration/mozilla-inbound/rev/61224f22f178
(not sure if we want this on the current aurora/beta trains; if so, patch will need approval to land there)

Anders: Thanks for the patch! For future patches, it'd be great if you could set up the patch to include a commit message & author name, as described here:
https://developer.mozilla.org/en/Mercurial_FAQ#How_can_I_generate_a_patch_for_somebody_else_to_check-in_for_me.3f
(In this case, I added that data before landing the patch.)
Keywords: checkin-needed
Whiteboard: [good first bug] → [good first bug][inbound]
Version: 5 Branch → Trunk
http://hg.mozilla.org/mozilla-central/rev/61224f22f178
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 8
(Reporter)

Updated

6 years ago
Severity: normal → major

Updated

6 years ago
Whiteboard: [good first bug][inbound] → [good first bug][inbound][qa+]

Comment 14

6 years ago
I have verified this bug by updating from:
Mozilla/5.0 (Windows NT 5.1; rv:5.0a2) Gecko/20110418 Firefox/5.0a2 to
Mozilla/5.0 (Windows NT 5.1; rv:9.0a2) Gecko/20111003 Firefox/9.0a2

from
Mozilla/5.0 (Windows NT 6.1; rv:5.0a2) Gecko/20110418 Firefox/5.0a2 to
Mozilla/5.0 (Windows NT 6.1; rv:9.0a2) Gecko/20111003 Firefox/9.0a2

from
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0a2) Gecko/20110418 Firefox/5.0a2 to
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0a2) Gecko/20111003 Firefox/9.0a2

from
Mozilla/5.0 (X11; Linux i686; rv:5.0a2) Gecko/20110416 Firefox/5.0a2to
Mozilla/5.0 (X11; Linux i686; rv:9.0a2) Gecko/20111004 Firefox/9.0a2

and all the updates were made perfectly, all on the Aurora channel. 

I have also updated Nightly on Windows 7 x86 from
Mozilla/5.0 (Windows NT 6.1; rv:6.0a1) Gecko/20110414 Firefox/6.0a1 to
Mozilla/5.0 (Windows NT 6.1; rv:10.0a1) Gecko/20111003 Firefox/10.0a1
and also made the update on Win XP, Mac OS 10.6 and Ubuntu 11.04 x86 and everything worked as expected

Considering this, setting resolution to Verified Fixed.
Status: RESOLVED → VERIFIED
Keywords: verified-aurora
Whiteboard: [good first bug][inbound][qa+] → [good first bug][inbound][qa!]
You need to log in before you can comment on or make changes to this bug.