The default bug view has changed. See this FAQ.

When Message view is "Grouped by sort", double-clicking anywhere but the expand/collapse arrow (eg in group heading) does not expand or collapse group

RESOLVED FIXED in Thunderbird 43.0

Status

Thunderbird
Folder and Message Lists
--
minor
RESOLVED FIXED
6 years ago
2 years ago

People

(Reporter: Adrian Perez, Assigned: alta88)

Tracking

unspecified
Thunderbird 43.0
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.17) Gecko/20110424 Thunderbird/3.1.10

View is set to sort by "Date" and "Group by sort". Trying to expand or collapse a group by double clicking anywhere but the arrow in the subject field does not work.
When a group is collapsed, double-clicking on the "Today" group header in subject field will open a new Thunderbird window with no tabs open.
When a group is already expanded double-clicking on the the group header row does nothing.

Reproducible: Always

Steps to Reproduce:
1.Set view to sort by "Date" and "Group by Sort"
2.Double-click on the group headers anywhere except the expand/collapse arrows
3.

Actual Results:  
When group is collapsed, new Thunderbird window opens with no open tabs.
When group is already expanded, nothing happens.

Expected Results:  
Double-clicking anywhere in the group header row should expand or collapse the respective group, such as in Outlook.
Aureliano, do you also see this ?
(In reply to comment #1)
>Double-clicking anywhere in the group header row should expand or collapse the >respective group, such as in Outlook.

Why? In TB to collapse\expande thread you must click (*1 click*) on expand/collapse arrows.
This because when you double click 

>Double-click on the group headers anywhere except the expand/collapse arrows

TB open message (or messages) in tab or new window based on your option.

In my opinion this is Invalid because the behavior is deliberate.
Reporter, 

do you still see this problem when using a current version of thunderbird? 

And if you do not, please close bug report by changing resolution to worksforme
Whiteboard: [closeme 2012-03-01]
RESOLVED INCOMPLETE due to lack of response to last question. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 5

5 years ago
Yes, I am still experiencing this issue with the current version of TB (10.0.2).

Based on Aureliano's comment it is apparent that these are deliberate behaviors.
In my opinion, expanding the groups should be possible from clicking anywhere on the header row but that would ultimately be a Wish List item though.

However, he did mention that double clicking on the collapsed group should open up the messages in new tabs or windows based on your preferences. In my case, the new windows open up but the messages are not displayed. Is that the desired behavior as well?
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
(In reply to Adrian Perez from comment #5)
> Yes, I am still experiencing this issue with the current version of TB
> (10.0.2).
> 
> Based on Aureliano's comment it is apparent that these are deliberate
> behaviors.
> In my opinion, expanding the groups should be possible from clicking
> anywhere on the header row but that would ultimately be a Wish List item
> though.

Blake, what do you think?

Current behavior may be intentional but I think this change would be useful. Double click on folders expands a list of subfolders. And this request seem analogous (except that double clicking threads will not work)
Severity: normal → minor
Summary: When Message view is "Grouped by sort" double-clicking anywhere but the expand/collapse arrow does not expand or collapse group → When Message view is "Grouped by sort", double-clicking anywhere but the expand/collapse arrow (eg in group heading) does not expand or collapse group
Whiteboard: [closeme 2012-03-01]
(Assignee)

Comment 7

2 years ago
The current behavior is all over the map, depending on whether it's a mail, feed, or news folder and also whether the dummy header is expanded/collapsed at the time and then on how mail.operate_on_msgs_in_collapsed_threads is set.  Opening implied multiselect messages sometimes works sometimes opens empty tabs.

This patch will make a click anywhere in the header (cyclers too) select the row, and make a double click anywhere toggle expand/collapse. An <enter> will also toggle.
Depends on: 500610
(Assignee)

Comment 8

2 years ago
Created attachment 8654661 [details] [diff] [review]
groupedHeaderDClickToggle.patch
Assignee: nobody → alta88
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8654661 - Flags: review?(mkmelin+mozilla)

Comment 9

2 years ago
Comment on attachment 8654661 [details] [diff] [review]
groupedHeaderDClickToggle.patch

Review of attachment 8654661 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM, r=mkmelin

::: mail/base/content/mailWindowOverlay.js
@@ +2148,5 @@
> +    let row = gFolderDisplay.treeSelection.count == 1 ?
> +                 gFolderDisplay.treeSelection.currentIndex : -1;
> +    if (gFolderDisplay.view.isGroupedByHeaderAtIndex(row))
> +      // Let tree.xml handle it.
> +      return;

Maybe instead

if (gFolderDisplay.view.showGroupedBySort &&
    gFolderDisplay.treeSelection.count == 1 && 
    gFolderDisplay.view.isGroupedByHeaderAtIndex(gFolderDisplay.treeSelection.currentIndex))
  return; // Let tree.xml handle it.
Attachment #8654661 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Comment 10

2 years ago
Created attachment 8656267 [details] [diff] [review]
groupedHeaderDClickToggle.patch

udpated for comment.
Attachment #8654661 - Attachment is obsolete: true
Attachment #8656267 - Flags: review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 11

2 years ago
https://hg.mozilla.org/comm-central/rev/17f00c3e74cbd94c5d6bfd653876f541ec47782f
Bug 655653 - When Message view is "Grouped by sort", double-clicking anywhere but the expand/collapse arrow (eg in group heading) does not expand or collapse group. r=mkmelin

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago2 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 43.0
You need to log in before you can comment on or make changes to this bug.