Last Comment Bug 655701 - Remove test dependencies on the html5.parser.enable pref
: Remove test dependencies on the html5.parser.enable pref
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: HTML: Parser (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla6
Assigned To: Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03)
:
:
Mentors:
Depends on:
Blocks: 462483 563890
  Show dependency treegraph
 
Reported: 2011-05-09 06:41 PDT by Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03)
Modified: 2011-05-17 06:34 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Remove html5.parser.enable deps from the tests (21.10 KB, patch)
2011-05-09 07:34 PDT, Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03)
ted: review+
Details | Diff | Splinter Review

Description Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2011-05-09 06:41:45 PDT
In order to get rid of the pref itself, we should get rid of all tests that assume that the pref exists.

ted, in reference to needing to remove these also due to universalXPConnect removal, do you already happen to have a patch for this?
Comment 1 Ted Mielczarek [:ted.mielczarek] 2011-05-09 06:45:41 PDT
No, it was just on the list of things that needed to be dealt with, I hadn't done anything about it.
Comment 2 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2011-05-09 06:55:59 PDT
OK.
Comment 3 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2011-05-09 07:34:43 PDT
Created attachment 531042 [details] [diff] [review]
Remove html5.parser.enable deps from the tests
Comment 4 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2011-05-10 01:39:10 PDT
Comment on attachment 531042 [details] [diff] [review]
Remove html5.parser.enable deps from the tests

Looks ok on try.
Comment 5 Ted Mielczarek [:ted.mielczarek] 2011-05-11 06:09:19 PDT
Comment on attachment 531042 [details] [diff] [review]
Remove html5.parser.enable deps from the tests

Review of attachment 531042 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, r=me

::: parser/htmlparser/tests/mochitest/test_compatmode.html
@@ +63,4 @@
>  function test(mode,i){
>    is(mode,doctypes[i],doctypes[i+1]);
>    if (i == doctypes.length - 2) {
> +    finishTest();

This could just become SimpleTest.finish() and remove the finishTest function. Doesn't matter all that much though.
Comment 6 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2011-05-12 01:03:58 PDT
(In reply to comment #5)
> Looks good, r=me

Thanks.

> This could just become SimpleTest.finish() and remove the finishTest
> function. Doesn't matter all that much though.

Landed with this changed.

http://hg.mozilla.org/mozilla-central/rev/63fe82a5f142

Note You need to log in before you can comment on or make changes to this bug.