Closed Bug 655726 Opened 10 years ago Closed 5 years ago

Attachment sizes not being shown for feeds despite size= in the part.

Categories

(Thunderbird :: Message Reader UI, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1284004

People

(Reporter: alta88, Unassigned)

References

Details

now the reverse problem, a feed with a mimepart containing size= nevertheless does not show that size in the UI.

here is the message source from article Storyboard: The Grand Unified Theory of Humor in a wired feed:
http://www.wired.com/magazine/feed/

--------------51320158651
Content-Type: audio/mpeg; name="Storyboard_048.mp3"; size=20158651
X-Mozilla-External-Attachment-URL: http://downloads.wired.com/podcasts/assets/Storyboard/Storyboard_048.mp3
Content-Disposition: attachment; filename="Storyboard_048.mp3"

This MIME attachment is stored separately from the message.
--------------51320158651--
in looking at this briefly, it seems that by the time the header gets to the messageHeaderSink functions, the size has been turned into size=null.

so the issue seems to be in the mime emitter.
Blocks: 646105
Blocks: 559559
being fixed in bug 1284004.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1284004
You need to log in before you can comment on or make changes to this bug.