All users were logged out of Bugzilla on October 13th, 2018

Firefox crashed when signing out from Yahoo Mail Beta [@ GCGraphBuilder::NoteXPCOMChild ]

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

({crash})

2.0 Branch
x86_64
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

I used a brand new Firefox installation with a new clean profile trying to reproduce the crash in bug bug 655660, but instead I stumbled upon the dead Delete button bug in bug 644014, comment 18. When I signed out for the first time Firefox crashed, but not with the signature from bug 655660 I'd hoped to get but with the current one.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1. Sign into Yahoo Mail Beta
2. Read mail and try to delete them and move them around.
3. Sign out.

Actual Results:  
Crash.

Expected Results:  
A clean sign out without crash.

0 		@0x7f36aac06780 	
1 	libxul.so 	GCGraphBuilder::NoteXPCOMChild 	xpcom/base/nsCycleCollector.cpp:1205
2 	libxul.so 	nsParser::cycleCollection::Traverse 	parser/htmlparser/src/nsParser.cpp:877
3 	libxul.so 	GCGraphBuilder::Traverse 	xpcom/base/nsCycleCollector.cpp:1523
4 	libxul.so 	nsCycleCollector::MarkRoots 	xpcom/base/nsCycleCollector.cpp:1764
5 	libxul.so 	nsCycleCollector::BeginCollection 	xpcom/base/nsCycleCollector.cpp:2633
6 	libxul.so 	nsCycleCollectorRunner::Run 	xpcom/base/nsCycleCollector.cpp:3321
7 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:633
8 	libxul.so 	NS_ProcessNextEvent_P 	nsThreadUtils.cpp:250
9 	libxul.so 	nsThread::ThreadFunc 	xpcom/threads/nsThread.cpp:277
10 	libnspr4.so 	_pt_root 	nsprpub/pr/src/pthreads/ptthread.c:187
11 	libpthread-2.13.so 	libpthread-2.13.so@0x6b3f
(Reporter)

Updated

8 years ago
Keywords: crash
Version: unspecified → 4.0 Branch
(Reporter)

Comment 1

8 years ago
Remembered almost everything...

but here is the Crash ID:
bp-f191518e-15f8-46d6-91e5-bc6092110509
(Reporter)

Updated

8 years ago
Component: General → XPCOM
Product: Firefox → Core
QA Contact: general → xpcom
Version: 4.0 Branch → unspecified
(Reporter)

Updated

8 years ago
Version: unspecified → 2.0 Branch
(Assignee)

Updated

8 years ago
Crash Signature: [@ GCGraphBuilder::NoteXPCOMChild ]

Comment 2

7 years ago
Thomas, are you still seeing/reproducing this crash when using newer version of firefox?
(Reporter)

Comment 3

7 years ago
No, "unfortunately" not.

I see in the crash comments section that this crash signature has started to show up again on both on Mac OS X and Linux in the last part of November, but judging all changes since FX 4.0.1 I guess there might be another root cause now.

Updated

7 years ago
Blocks: 469267
Closing this for now.  Please reopen if you see this issue again.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.