Closed Bug 655912 Opened 9 years ago Closed 9 years ago

install-module.pl is unable to install LWP::UserAgent on Perl <5.8.8, because LWP 6.0 now requires 5.8.8 as a minimum

Categories

(Bugzilla :: Installation & Upgrading, defect)

4.1.2
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Bugzilla 4.0

People

(Reporter: LpSolit, Assigned: LpSolit)

References

Details

(Whiteboard: [blocker will fix for 5.0])

Attachments

(1 file)

Same problem as in bug 631328, but for LWP against Perl 5.8.7 and older.
We may be able to make install-module pick the older 5.x version.
Flags: blocking4.0.2+
Whiteboard: [blocker will fix] → [blocker will fix for 5.0]
Flags: blocking4.2+
Target Milestone: --- → Bugzilla 4.0
Assignee: installation → mkanat
Can we have this bug fixed before we release 4.0.2, please?
Attached patch patch, v1Splinter Review
Assignee: mkanat → LpSolit
Status: NEW → ASSIGNED
Attachment #549575 - Flags: review?(mkanat)
Comment on attachment 549575 [details] [diff] [review]
patch, v1

Okay. If you've tested this and it works, then it looks fine to me.
Attachment #549575 - Flags: review?(mkanat) → review+
Flags: approval4.0+
Flags: approval+
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified Bugzilla/Install/CPAN.pm
Committed revision 7875.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.0/
modified Bugzilla/Install/CPAN.pm
Committed revision 7627.
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.