Closed Bug 655975 Opened 9 years ago Closed 9 years ago

display glitch on buttons previous and next on tool-bar when an account is selected

Categories

(Thunderbird :: Toolbars and Tabs, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 6.0

People

(Reporter: roger21, Assigned: Paenglab)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.17) Gecko/20110422 Ubuntu/10.10 (maverick) Firefox/3.6.17
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.17) Gecko/20110424 Thunderbird/3.1.10

the tool-bar icons of the buttons "previous" and "next" (move to previous/next unread message) are not displayed as expected when an account or the local folder is selected in the left pane

if a mail is selected (in the right pane) or a mail folder (in the left pane) the display is fine

Reproducible: Always

Steps to Reproduce:
1.use the tool-bar customize feature to add the previous and next buttons in the tool-bar or menu-bar
2.select a mail account in the left pane or the local folder


Actual Results:  
the icons are displayed weirdly : the previous icon is replaced by a micro tiny buggy thing larger than a normal icon and the next icon become void

Expected Results:  
the icons could be grayed as the other disabled tool-bar icons in this case
The definitions for small tool bars had no !important flag and where overruled by the definitions for normal tool bars with this flag
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #531300 - Flags: review?(nisses.mail)
thanks, it works for me by adding those "!important" rules to my userChrome.css
Comment on attachment 531300 [details] [diff] [review]
Make definition for small toolbar stronger

This takes care of the issue and the use of !important is consistent with the other classes using [disabled]
Attachment #531300 - Flags: review?(nisses.mail) → review+
Keywords: checkin-needed
Checked in: http://hg.mozilla.org/comm-central/rev/f314c7f8580f
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.4
You need to log in before you can comment on or make changes to this bug.