Last Comment Bug 656021 - Update Scratchpad menu access key to S
: Update Scratchpad menu access key to S
Status: VERIFIED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 6
Assigned To: Rob Campbell [:rc] (:robcee)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-05-10 08:14 PDT by Rob Campbell [:rc] (:robcee)
Modified: 2011-08-02 10:25 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
[checked-in] change scratchpad accesskey to 's' (1.11 KB, patch)
2011-05-10 08:18 PDT, Rob Campbell [:rc] (:robcee)
l10n: review+
Details | Diff | Splinter Review

Description Rob Campbell [:rc] (:robcee) 2011-05-10 08:14:50 PDT
Was supposed to get this before landing bug 653221 but missed it. We should move the access key to 'S' for en-US in the Web Developer menu.
Comment 1 Rob Campbell [:rc] (:robcee) 2011-05-10 08:18:47 PDT
Created attachment 531333 [details] [diff] [review]
[checked-in] change scratchpad accesskey to 's'
Comment 2 Shawn Wilsher :sdwilsh 2011-05-10 08:19:53 PDT
Since this has landed on mozilla-central now, I think you need to change the entity name as well so localizers know that it has changed.
Comment 3 Rob Campbell [:rc] (:robcee) 2011-05-10 08:23:07 PDT
augh, imo.
Comment 4 Axel Hecht [:Pike] 2011-05-10 08:28:52 PDT
Comment on attachment 531333 [details] [diff] [review]
[checked-in] change scratchpad accesskey to 's'

r=me on landing this without a key change, as this is the same context.

Post in .l10n for those using en-US accesskeys is good enough.
Comment 5 Rob Campbell [:rc] (:robcee) 2011-05-10 09:12:41 PDT
Comment on attachment 531333 [details] [diff] [review]
[checked-in] change scratchpad accesskey to 's'

http://hg.mozilla.org/mozilla-central/rev/a99f84efbb20
Comment 6 Daniel Veditz [:dveditz] 2011-05-11 15:13:05 PDT
's' is already the accesskey for "Save page as...". Is that one changing? Is there a qualifier (shift?) that I'm not seeing in this patch?
Comment 7 Rob Campbell [:rc] (:robcee) 2011-05-11 15:35:35 PDT
accesskey is just to "access" the feature when navigating the menus with keyboard. accelerator/commandkey for the Scratchpad is F4. Doesn't conflict with Save As.
Comment 8 Simona B [:simonab ] 2011-05-12 05:54:14 PDT
Mozilla/5.0 (Windows NT 6.1; rv:6.0a1) Gecko/20110511 Firefox/6.0a1

Verified on Linux and Windows, 's' key brings up the Scratchpad when navigating through the menu. Even if the platform for this issue is set to Mac OS X, the same behaviour is not encountered on Mac. Should this apply for Mac also?
Comment 9 Rob Campbell [:rc] (:robcee) 2011-05-12 07:04:34 PDT
Simona, my mistake. I filed on a Mac and those fields were pre-populated for me.

Accesskey behavior's a little funny on the Mac and not really consistent with Windows and Linux.

Thanks for verifying this!

Note You need to log in before you can comment on or make changes to this bug.