Last Comment Bug 653221 - Create Web Developer Sub-menu in the Tools menu
: Create Web Developer Sub-menu in the Tools menu
Status: VERIFIED FIXED
[fixed-in-devtools][merged-to-mozilla...
: dev-doc-complete, ux-jargon, ux-visual-hierarchy
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: unspecified
: All All
: -- normal (vote)
: Firefox 6
Assigned To: Rob Campbell [:rc] (:robcee)
:
Mentors:
Depends on: 653093 656360 657088
Blocks: 656858
  Show dependency treegraph
 
Reported: 2011-04-27 12:54 PDT by Rob Campbell [:rc] (:robcee)
Modified: 2012-05-03 07:31 PDT (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Web Developer submenu (3.65 KB, patch)
2011-04-27 13:16 PDT, Rob Campbell [:rc] (:robcee)
dao+bmo: review-
Details | Diff | Splinter Review
[checked-in][in-devtools] Web Developer submenu (8.30 KB, patch)
2011-05-05 17:35 PDT, Rob Campbell [:rc] (:robcee)
dao+bmo: review+
Details | Diff | Splinter Review

Description Rob Campbell [:rc] (:robcee) 2011-04-27 12:54:19 PDT
The Tools menu should have a Web Developer sub menu to contain various devtools features. The Inspect menu item and Scratchpad are going to be the initial inhabitants.
Comment 1 Dão Gottwald [:dao] 2011-04-27 13:04:58 PDT
(In reply to comment #0)
> The Inspect menu item and Scratchpad are going to be the initial
> inhabitants.

And the Web Console, I assume. It might make sense to move Page Source from the View menu, too.
Comment 2 Rob Campbell [:rc] (:robcee) 2011-04-27 13:16:22 PDT
Created attachment 528695 [details] [diff] [review]
Web Developer submenu

patch to add web developer submenu to to the Tools menu. Re-using the app menu's label, currently, though we can create a new one if-needed.

Also moved the Error Console in there as it seemed to fit.
Comment 3 Dão Gottwald [:dao] 2011-04-27 13:18:29 PDT
Given the entity's name (appMenu...), I think you need to create a new one. You also need to add an access key.
Comment 4 Philip Chee 2011-04-27 17:54:39 PDT
The old Mozilla Suite had a Tools->Web Development and SeaMonkey inherited that. When Firefox was forked, this submenu was removed on the grounds that having submenus reduces ease of discovery not to mention the general ux-suck of submenus.

Can you guys run this sort of thing past the UX people before going down the garden path?
Comment 5 Panos Astithas [:past] 2011-04-28 06:37:39 PDT
As another data point, Chrome has only one submenu under the wrench/tools icon, 'Tools', with contents that contain developer features, among others.
Comment 6 Rob Campbell [:rc] (:robcee) 2011-04-28 09:06:00 PDT
Good points Philip and Panos. CC'ing Limi for a consult.
Comment 7 Dão Gottwald [:dao] 2011-05-05 07:47:41 PDT
Comment on attachment 528695 [details] [diff] [review]
Web Developer submenu

Apart from comment 3, it looks like menu-iconic slipped in incorrectly:

>+              <menu id="webDeveloperMenu"
>+                    class="menu-iconic"
>+                    label="&appMenuWebDeveloper.label;">
Comment 8 Rob Campbell [:rc] (:robcee) 2011-05-05 14:35:23 PDT
Received a go-ahead from limi on this yesterday in IRC so it looks like we can add this submenu to Tools.

Dao, I'll address your comments and add a new entity as well as a fix for the errant "menu-iconic" class. Can I just omit the class attribute in this case?

I'll add a unittest as well.
Comment 9 Dão Gottwald [:dao] 2011-05-05 14:36:46 PDT
(In reply to comment #8)
> Can I just omit the class attribute in this case?

Yep
Comment 10 Rob Campbell [:rc] (:robcee) 2011-05-05 17:35:14 PDT
Created attachment 530474 [details] [diff] [review]
[checked-in][in-devtools] Web Developer submenu

addressed comments, moved page source into submenu and added a basic test for the existence of menu items.
Comment 11 Dão Gottwald [:dao] 2011-05-06 00:31:37 PDT
Comment on attachment 530474 [details] [diff] [review]
[checked-in][in-devtools] Web Developer submenu

You were also going to change the Scratchpad access key to S. You can make it so right away if you land this patch together with bug 653093.

(The test doesn't really seem useful.)
Comment 12 Rob Campbell [:rc] (:robcee) 2011-05-06 05:30:41 PDT
(In reply to comment #11)
> Comment on attachment 530474 [details] [diff] [review] [review]
> Web Developer submenu
> 
> You were also going to change the Scratchpad access key to S. You can make
> it so right away if you land this patch together with bug 653093.
> 
> (The test doesn't really seem useful.)

Agreed, it's only checking for existence and not much else. We do verify the prefs for the various features in the menus in other tests so I suppose they're covered. Only other thing I could do is verify that the commands associated with those tests are what we're expecting them to be.

I'll update the accesskey, before landing though.

Still waiting for feedback on bug 653093.
Comment 13 Alex Limi (:limi) — Firefox UX Team 2011-05-06 19:43:46 PDT
(In reply to comment #8)
> Received a go-ahead from limi on this yesterday in IRC so it looks like we
> can add this submenu to Tools.

Just to give some context here, I'm usually against submenus for obvious reasons (discoverability, slow access and other things), but in this case, I think it's specialized enough to make sense. We should also try to make it consistent across Windows/Mac and both the traditional menu and the new Windows one.
Comment 14 Axel Hecht [pto-Aug-30][:Pike] 2011-05-08 13:57:20 PDT
Chiming in here from a l10n perspective, I've got comments that doing a translation of "scratchpad" is gonna be much easier and understandable if it's in the context of a web developer menu already.

It'd be great if we could land this and the scratchpad bug in one go if we're moving around the accesskey. That might be painful for the folks tracking l10n-central.
Comment 15 Rob Campbell [:rc] (:robcee) 2011-05-09 05:57:37 PDT
yep, I plan to land these as a pair.

thanks for the reviews!
Comment 16 Rob Campbell [:rc] (:robcee) 2011-05-09 06:00:50 PDT
(In reply to comment #13)
> (In reply to comment #8)
> > Received a go-ahead from limi on this yesterday in IRC so it looks like we
> > can add this submenu to Tools.
> 
> Just to give some context here, I'm usually against submenus for obvious
> reasons (discoverability, slow access and other things), but in this case, I
> think it's specialized enough to make sense. We should also try to make it
> consistent across Windows/Mac and both the traditional menu and the new
> Windows one.

content-wise, these are the same. I'll shuffle the entries in the Tools submenu to match what is already in the App Menu.
Comment 17 Rob Campbell [:rc] (:robcee) 2011-05-09 09:32:29 PDT
Comment on attachment 530474 [details] [diff] [review]
[checked-in][in-devtools] Web Developer submenu

http://hg.mozilla.org/projects/devtools/rev/c9cf95f38c54
Comment 18 Rob Campbell [:rc] (:robcee) 2011-05-09 12:59:45 PDT
Comment on attachment 530474 [details] [diff] [review]
[checked-in][in-devtools] Web Developer submenu

http://hg.mozilla.org/mozilla-central/rev/c9cf95f38c54
Comment 19 Dão Gottwald [:dao] 2011-05-10 06:39:43 PDT
> I'll update the accesskey, before landing though.

This didn't actually happen.
Comment 20 Rob Campbell [:rc] (:robcee) 2011-05-10 08:15:10 PDT
(In reply to comment #19)
> > I'll update the accesskey, before landing though.
> 
> This didn't actually happen.

aw nuts. I thought I did it.

filed bug 656021.
Comment 21 AndreiD[QA] 2011-05-12 07:21:49 PDT
Verified Fixed on:
Mozilla/5.0 (Windows NT 6.1; rv:6.0a1) Gecko/20110511 Firefox/6.0a1
Mozilla/5.0 (X11; Linux i686; rv:6.0a1) Gecko/20110512 Firefox/6.0a1
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0a1) Gecko/20110511 Firefox/6.0a1
Comment 22 Satish 2011-05-13 19:45:28 PDT
(In reply to comment #1)
> (In reply to comment #0)
> > The Inspect menu item and Scratchpad are going to be the initial
> > inhabitants.
> 
> And the Web Console, I assume. It might make sense to move Page Source from
> the View menu, too.
OK... this is major UX change. From the beginning of Firefox 1.0 I have been accustomed to use the Alt+V+O to view the source. Now I need to go to Tools->Web Developer->View Source. This is very annoying. Is it possible to move it back to "View" menu? Please move it back...
Comment 23 Philip Chee 2011-05-13 20:01:16 PDT
IMO View source is used by people other than Web developers. For example this would be used by support volunteers in order to diagnose problems reported by users.
Comment 24 Satish 2011-05-13 20:12:36 PDT
(In reply to comment #23)
> IMO View source is used by people other than Web developers. For example
> this would be used by support volunteers in order to diagnose problems
> reported by users.
You are right. View Source is not just for Web Developers. IMHO it must be in the "View" menu as it had been there from the inception of Firefox.
Comment 25 Dão Gottwald [:dao] 2011-05-14 00:18:30 PDT
(In reply to comment #22)
> OK... this is major UX change. From the beginning of Firefox 1.0 I have been
> accustomed to use the Alt+V+O to view the source. Now I need to go to
> Tools->Web Developer->View Source. This is very annoying.

You can hit Ctrl+U.

(In reply to comment #23)
> IMO View source is used by people other than Web developers. For example
> this would be used by support volunteers in order to diagnose problems
> reported by users.

This ship has sailed already with the introduction of the Firefox button.
Comment 26 Satish 2011-05-14 06:14:39 PDT
(In reply to comment #25)
> (In reply to comment #22)
> > OK... this is major UX change. From the beginning of Firefox 1.0 I have been
> > accustomed to use the Alt+V+O to view the source. Now I need to go to
> > Tools->Web Developer->View Source. This is very annoying.
> 
> You can hit Ctrl+U.
> 
> (In reply to comment #23)
> > IMO View source is used by people other than Web developers. For example
> > this would be used by support volunteers in order to diagnose problems
> > reported by users.
> 
> This ship has sailed already with the introduction of the Firefox button.

Which version is was sailed? In the 4.0 build it is still under view menu. IE9 still has the "Source" menu under "View" menu. So why Firefox is moving it? Also what other menus are there in the "View" menu which is making it cluttered, which made the team to move it to some other place? Changes are welcome but not for that which are not needed. I have been using Firefox since "Phoenix/Firebird" and this is stunning to me. Please listen to the user community.
Comment 27 Philip Chee 2011-05-14 08:15:20 PDT
It's a bit presumptious to claim that you speak for the "user community". Have you taken a poll? Do you have any statistics to back your claim?
Comment 28 Satish 2011-05-14 08:38:47 PDT
OK...I guess my comments are starting an unhealthy discussion. Sorry for that. I will start using Ctrl+U and concentrate on continuing my testing of nightly builds.
Comment 29 Satish 2011-11-04 07:50:57 PDT
(In reply to Philip Chee from comment #27)
> It's a bit presumptious to claim that you speak for the "user community".
> Have you taken a poll? Do you have any statistics to back your claim?

Was there any poll/statistics which prompted to move the "Page Source" from View menu to a an entirely new Web Developers menu? I see that it was just suggested by one person as mentioned below:

========
Dão Gottwald [:dao] 2011-04-27 13:04:58 PDT 

And the Web Console, I assume. It might make sense to move Page Source from the View menu, too.
========
Comment 30 Rob Campbell [:rc] (:robcee) 2011-11-04 09:25:20 PDT
(In reply to Satish from comment #29)
> (In reply to Philip Chee from comment #27)
> > It's a bit presumptious to claim that you speak for the "user community".
> > Have you taken a poll? Do you have any statistics to back your claim?
> 
> Was there any poll/statistics which prompted to move the "Page Source" from
> View menu to a an entirely new Web Developers menu? I see that it was just
> suggested by one person as mentioned below:
> 
> ========
> Dão Gottwald [:dao] 2011-04-27 13:04:58 PDT 
> 
> And the Web Console, I assume. It might make sense to move Page Source from
> the View menu, too.
> ========

I think the rationale was that on systems without a View menu showing (menu bar hidden, tabs on top), the View Source menu item would be orphaned. Maybe we should consider moving it back into the View menu if shown, Web Developer menu otherwise.

Might be worth opening a bug for this.
Comment 31 Satish 2011-11-04 10:39:55 PDT
(In reply to Rob Campbell [:rc] (robcee) from comment #30)
> (In reply to Satish from comment #29)
> > (In reply to Philip Chee from comment #27)
> > > It's a bit presumptious to claim that you speak for the "user community".
> > > Have you taken a poll? Do you have any statistics to back your claim?
> > 
> > Was there any poll/statistics which prompted to move the "Page Source" from
> > View menu to a an entirely new Web Developers menu? I see that it was just
> > suggested by one person as mentioned below:
> > 
> > ========
> > Dão Gottwald [:dao] 2011-04-27 13:04:58 PDT 
> > 
> > And the Web Console, I assume. It might make sense to move Page Source from
> > the View menu, too.
> > ========
> 
> I think the rationale was that on systems without a View menu showing (menu
> bar hidden, tabs on top), the View Source menu item would be orphaned. Maybe
> we should consider moving it back into the View menu if shown, Web Developer
> menu otherwise.
> 
> Might be worth opening a bug for this.

Nice option. I already have a bug related to this, so I will put this comment there. The bug is: Bug 657088
Comment 32 Eric Shepherd [:sheppy] 2012-05-03 07:31:21 PDT
Dev docs already cover this stuff.

Note You need to log in before you can comment on or make changes to this bug.