Last Comment Bug 656587 - hg account creation request [Nilamdyuti Goswami - Assamese]
: hg account creation request [Nilamdyuti Goswami - Assamese]
Status: RESOLVED FIXED
:
Product: Mozilla Localizations
Classification: Client Software
Component: as / Assamese (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 694318
  Show dependency treegraph
 
Reported: 2011-05-12 04:55 PDT by Nilamdyuti
Modified: 2011-12-22 08:06 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Assamese Translation Updates for Firefox 4 (696.91 KB, application/octet-stream)
2011-05-12 04:58 PDT, Nilamdyuti
no flags Details
Patch for Assamese hg directory (643.86 KB, patch)
2011-05-17 05:51 PDT, Nilamdyuti
no flags Details | Diff | Review
updated diff (560.71 KB, patch)
2011-05-18 03:17 PDT, Axel Hecht [:Pike]
l10n: review+
Details | Diff | Review

Description Nilamdyuti 2011-05-12 04:55:18 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.15) Gecko/20110318 Red Hat/3.6.15-2.el6_0 Firefox/3.6.15
Build Identifier: 

Hi,

I am Nilamdyuti Goswami. Since last couple of months I have been working on localizations for various open source projects like Gnome, KDE, LibreOffice after I joined Red Hat as a Language Maintainer for Assamese.

I have already sent the Assamese translations for Firefox 4.0 to the Amitakhya Phukan, coordinator of the Assamese team. He will upload it soon after review. Meanwhile, I am opening a request for my Hg account creation. I have attached the tarball of Assamese Translations of Firefox 4.0 for the reference.

CC'ing Amitakhya Phukan, current co-ordinator for vouching my request.

Reproducible: Always
Comment 1 Nilamdyuti 2011-05-12 04:58:03 PDT
Created attachment 531891 [details]
Assamese Translation Updates for Firefox 4

Translations attached for reference.
Comment 2 Axel Hecht [:Pike] 2011-05-12 05:26:40 PDT
Hi Nilamdyuti, great to see some activity on Assamese.

I'd like to see two things here, one is a check on the localization, which I'll rely on Amitakhya on. But I'd also like to make sure that the technical stuff around hg is in check, and for that, I'd actually prefer a patch for the assamese hg directory rather than a full tarball. Preferably, the patch should be against http://hg.mozilla.org/releases/l10n/mozilla-aurora/as/, as that's the repo where we're going forward with the l10n efforts in the new release scheme.
Comment 3 Nilamdyuti 2011-05-17 05:51:13 PDT
Created attachment 532940 [details] [diff] [review]
Patch for Assamese hg directory

Hi Axel,

As asked for, I have attached the patch for Assamese hg directory.

Regards,
Nilamdyuti Goswami
Comment 4 Amitakhya Phukan 2011-05-18 02:23:03 PDT
Hello all,

I am going through the patch sent by Nilam and I would like to make a few small (very small indeed) changes to preserve consistency amongst various translations done for Assamese till now.
Comment 5 Amitakhya Phukan 2011-05-18 02:36:52 PDT
Lets go for the push. We will standardise the translations at a later stage for coming releases and that should be good enough.

Pike, I will look forward to your help in this.

Nilam, congratulations on your good work. Welcome aboard to Assamese translation team in Mozilla.
Comment 6 Nilamdyuti 2011-05-18 03:07:04 PDT
Hi Amit,

Thanks a lot.
Comment 7 Axel Hecht [:Pike] 2011-05-18 03:17:05 PDT
Created attachment 533228 [details] [diff] [review]
updated diff

So, the patch didn't apply. The first attachment is an hg repo with local edits, so I used that to create this patch.

I think this is slightly older than the status of the patch in the second attachment, but I don't know how that came to be.

Here's what I did to get to the diff attached:

First, removed all the ~ files, then ran compare-locales to check that things work better. Then I compared the missing and new files in the hg repo with the report in compare-locales to see that hg addremove is a good idea, and did that.

Then hg diff.
Comment 8 Nilamdyuti 2011-05-18 05:08:23 PDT
Hi Axel,

Is there anything I need to do now?
Comment 9 Axel Hecht [:Pike] 2011-05-20 07:23:14 PDT
Nilam, I'd like to know how you did that diff? Because that itsel didn't apply at all, but looking at your first attachment, it would have been hard to get to that?
Comment 10 Axel Hecht [:Pike] 2011-06-20 03:42:59 PDT
Amit, ping?
Comment 11 Nilamdyuti 2011-06-21 00:07:26 PDT
Hi Axel,

I did that diff with diff command.
Comment 12 Shyam Mani [:fox2mike] 2011-09-09 11:18:06 PDT
1) This is *not* a repository access request

2) When it's not 1) it's in the wrong component. 

3) It's been stagnant for 3 months.

Moving out of IT.
Comment 13 Axel Hecht [:Pike] 2011-10-13 07:45:20 PDT
Comment on attachment 533228 [details] [diff] [review]
updated diff

We had a r+ on irc, sorry for the lag.

I filed bug 694318 to be just about the account, to make it more obvious which data we have and which not.
Comment 14 Axel Hecht [:Pike] 2011-12-22 08:06:40 PST
The account is there, and Nilamdyuti landed a bunch of patches on hg himself now, so closing this bug out.

Note You need to log in before you can comment on or make changes to this bug.