Google maps stops working after panning around a little

RESOLVED DUPLICATE of bug 656875

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 656875
7 years ago
5 years ago

People

(Reporter: Joe Drew (not getting mail), Assigned: Ehsan)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---

Firefox Tracking Flags

(firefox6-)

Details

(URL)

(Reporter)

Description

7 years ago
I've noticed this the past week or so. Lots of google maps pages (like the background of the Bixi Toronto page, linked) stop working after panning around a little bit. That is, tiles don't load and you can't interact with the map any more (no more panning).

I can reproduce this at will on the linked page by waiting for everything to load on the page (there are red markers that load on the page), then clicking and dragging the map to the right, and then releasing. The tiles don't load, and I can no longer interact with the map.

Here's a screenshot of what it looks like in this case: http://grab.by/a8bw
(Reporter)

Comment 1

7 years ago
Oh, I should have mentioned: no errors show up in the error console when this happens.

Comment 2

7 years ago
Regression window(cached m-c hourly):
Works:
http://hg.mozilla.org/mozilla-central/rev/8d0ca70728ff
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110505 Firefox/6.0a1 ID:20110506095431
Fails:
http://hg.mozilla.org/mozilla-central/rev/14fe8a6cfd45
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:6.0a1) Gecko/20110505 Firefox/6.0a1 ID:20110506112151
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8d0ca70728ff&tochange=14fe8a6cfd45
Triggered by:
Bug 10209 - problems with absolute or fixed position on table [ABS POS] [FIX POS]
Blocks: 10209
tracking-firefox6: --- → ?
Component: General → Layout
Keywords: regressionwindow-wanted
OS: Mac OS X → All
QA Contact: general → layout
Ehsan, is this fixed by your latest patches?
(Assignee)

Comment 4

7 years ago
I think this should be a dupe of bug 656875.  It would be great if you guys can test this in these try server builds:

<https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/eakhgari@mozilla.com-2cdead0a2cb7/>
Assignee: nobody → ehsan

Comment 5

7 years ago
(In reply to comment #4)
> I think this should be a dupe of bug 656875.  It would be great if you guys
> can test this in these try server builds:
> 
> <https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/eakhgari@mozilla.
> com-2cdead0a2cb7/>
I run it on Windows7 and Ubuntu10.04.
And I confirm that the tryServer build works fine on Windows7 and Ubuntu10.04.
(Assignee)

Comment 6

7 years ago
I can't repro on the try server build myself.
(Assignee)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 656875

Updated

7 years ago
tracking-firefox6: ? → -
You need to log in before you can comment on or make changes to this bug.