Last Comment Bug 656875 - Scaling down the body makes the smallest text pieces disappear.
: Scaling down the body makes the smallest text pieces disappear.
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: General (show other bugs)
: Trunk
: x86 All
: -- normal (vote)
: mozilla10
Assigned To: :Ehsan Akhgari (out sick)
:
Mentors:
: 657182 657403 691166 691624 (view as bug list)
Depends on:
Blocks: 10209 691087
  Show dependency treegraph
 
Reported: 2011-05-13 03:54 PDT by Paul Rouget [:paul]
Modified: 2011-10-04 02:07 PDT (History)
12 users (show)
ehsan: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments
bug (1.47 KB, text/html)
2011-05-13 03:54 PDT, Paul Rouget [:paul]
no flags Details
Reduced test case (189 bytes, text/html)
2011-05-15 13:25 PDT, :Ehsan Akhgari (out sick)
no flags Details
Patch (v1) (1.98 KB, patch)
2011-05-15 15:12 PDT, :Ehsan Akhgari (out sick)
roc: review+
Details | Diff | Review

Description Paul Rouget [:paul] 2011-05-13 03:54:03 PDT
Created attachment 532166 [details]
bug

In this page, the body is scaled down according to the size of the window, to make the 800x600 content fit in the window.

To reproduce, resize the window (make it smaller), until some text starts to disappear.

Once "scale(0.715)" is reached, some pieces of the text start to disappear.
First, the footer. At "scale(0.685)", the 7 first words. At "scale(0.5)", everything.

I say "pieces" because it doesn't look like DOM related. Sometimes, just a letter disappear (if the letter happens to be smaller than the others).
Comment 1 Alice0775 White 2011-05-13 04:35:27 PDT
Regression window(cached m-c hourly):
Works:
http://hg.mozilla.org/mozilla-central/rev/8d0ca70728ff
Mozilla/5.0 (X11; Linux i686; rv:6.0a1) Gecko/20110506 Firefox/6.0a1 ID:20110506095431
Fails:
http://hg.mozilla.org/mozilla-central/rev/14fe8a6cfd45
Mozilla/5.0 (X11; Linux i686; rv:6.0a1) Gecko/20110506 Firefox/6.0a1 ID:20110506112151
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8d0ca70728ff&tochange=14fe8a6cfd45
Triggered by:
Bug 10209 - problems with absolute or fixed position on table [ABS POS] [FIX POS]
Comment 2 XtC4UaLL [:xtc4uall] 2011-05-14 04:29:31 PDT
Seeing this on Win XP too (Mozilla/5.0 (Windows NT 5.1; rv:6.0a1) Gecko/20110513 Firefox/6.0a1 ID:20110513214941).
Comment 3 :Ehsan Akhgari (out sick) 2011-05-15 13:25:38 PDT
Created attachment 532525 [details]
Reduced test case

This page appears blank (no need to resize the browser window)
Comment 4 :Ehsan Akhgari (out sick) 2011-05-15 15:12:48 PDT
Created attachment 532533 [details] [diff] [review]
Patch (v1)
Comment 5 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-05-15 18:53:00 PDT
Comment on attachment 532533 [details] [diff] [review]
Patch (v1)

Review of attachment 532533 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 6 :Ehsan Akhgari (out sick) 2011-05-16 08:44:00 PDT
*** Bug 657182 has been marked as a duplicate of this bug. ***
Comment 7 Alice0775 White 2011-05-16 10:56:15 PDT
*** Bug 657403 has been marked as a duplicate of this bug. ***
Comment 8 :Ehsan Akhgari (out sick) 2011-05-16 11:14:31 PDT
http://hg.mozilla.org/mozilla-central/rev/ba4a4081f6a3
Comment 9 Vlad [QA] 2011-07-28 00:16:43 PDT
I've tried to reproduce this and everything looks ok now. The text doesn't disappear when I resize the window.

Setting resolution to Verified Fixed on Mozilla/5.0 (Windows NT 6.1; rv:6.0) Gecko/20100101 Firefox/6.0b3
Comment 10 :Ehsan Akhgari (out sick) 2011-10-03 16:33:50 PDT
I forgot to reland this bug when I landed bug 10209 again.  :(
Comment 11 :Ehsan Akhgari (out sick) 2011-10-03 16:37:55 PDT
Pushed to inbound again:

https://hg.mozilla.org/integration/mozilla-inbound/rev/c6b76256ebb2
Comment 12 :Ehsan Akhgari (out sick) 2011-10-03 16:40:52 PDT
*** Bug 691166 has been marked as a duplicate of this bug. ***
Comment 13 Matt Woodrow (:mattwoodrow) (PTO until 27 June) 2011-10-03 18:37:28 PDT
*** Bug 691624 has been marked as a duplicate of this bug. ***
Comment 14 Marco Bonardo [::mak] 2011-10-04 02:07:26 PDT
https://hg.mozilla.org/mozilla-central/rev/c6b76256ebb2

Note You need to log in before you can comment on or make changes to this bug.