Thunderbird doesn't ask for password after failed POP3 login

VERIFIED DUPLICATE of bug 428611

Status

Thunderbird
Account Manager
--
major
VERIFIED DUPLICATE of bug 428611
7 years ago
7 years ago

People

(Reporter: fabrizio.ge, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.17) Gecko/20110424 Thunderbird/3.1.10

If I enter a wrong password while checking my POP3 account for new e-mails, Thunderbird, as expected, shows the error message "authorization failed". However, if I click on the "Get Mail" toolbar button again, Thunderbird does not ask for a new password and instead tries to use the wrong password I entered in my previous attempt, which results in another "authorization failed" message.

Because of this problem, if I enter a wrong password by accident when I want to check my POP3 account, I have to restart Thunderbird so that I can enter the correct password and actually receive my e-mails.

Using Thunderbird 3.1.10 from Ubuntu 11.04

Reproducible: Always

Steps to Reproduce:
1.Configure a POP account
2.Check mail on that account
3.Type a wrong password
4.Verify that the error message box "Invalid username/password" only has an OK button, no "Insert new password" button
5.Check mail on that account again


Actual Results:  
When the server replies "Invalid username/password", a box asking for a new password should be shown

Expected Results:  
6.Verify that you get the error message box "Invalid username/password" without being asked for a new password

Comment 1

7 years ago
This should be fixed (for most if not all cases) in the upcoming 3.3 release.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 428611
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.