The default bug view has changed. See this FAQ.

The Composer status bar doesn't display the correct status.

RESOLVED FIXED in seamonkey2.2

Status

SeaMonkey
Composer
--
major
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Xindong Su, Assigned: Ian Neal)

Tracking

({regression})

Trunk
seamonkey2.2
regression
Bug Flags:
in-testsuite -

SeaMonkey Tracking Flags

(seamonkey2.2 fixed, seamonkey2.3 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.2; rv:2.0.1) Gecko/20110511 Firefox/4.0.1 SeaMonkey/2.1
Build Identifier: Mozilla/5.0 (Windows NT 5.2; rv:2.0.1) Gecko/20110511 Firefox/4.0.1 SeaMonkey/2.1

1. use composer to open any html file/url. No matter where you click on the page, the status bar always and only shows "<body>".

2. locate the cursor into some structure of the page, like a table. Switch to "source edit" mode then switch back to "Normal" mode, the status bar shows the right html tags of the cursor location. But the content of the status bar won't update when you move the cursor.


Reproducible: Always

Steps to Reproduce:
see the bug details.


Expected Results:  
the status bar should work like before.

Comment 1

6 years ago
Hi 
I have the same behavior.

I have found a part of the Problem:

The command cmd_updateStructToolbar is transfered from commandset composerStyleMenuItems in editorOverlay.xul to editorCommands in editor.xul

When i changed the focus only the command update from all composerStyleMenuItems commands are triggered. 

I don't find the source of this trigger.

Comment 2

6 years ago
cc IanN on the assumption that his refactoring caused this.
Summary: the status bar is malfunction → The Composer status bar doesn't display the correct status.

Comment 3

6 years ago
cmd_updateStructToolbar belongs in composerStyleMenuItems but it got put into composerOnlyMenuItems by mistake...
Blocks: 639716
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
OS: Windows Server 2003 → All
Hardware: x86 → All
(Assignee)

Updated

6 years ago
Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Version: unspecified → Trunk
(Assignee)

Comment 4

6 years ago
Created attachment 540364 [details] [diff] [review]
Move to correct commandset [Checked in trunk/aurora/beta: Comment 11]
Attachment #540364 - Flags: review?(neil)

Comment 5

6 years ago
I have determined where the command is triggered.

composerStyleMenuItems has the events="create, style, mode_switch"
composerOnlyMenuItems  has only events="create, mode_switch"

There are two options:
1. like comment 4 
   move cmd_updateStructToolbar back to composerStyleMenuItems

2. use the patch below

diff -r a4ca77b7517a editor/ui/composer/content/editor.xul
--- a/editor/ui/composer/content/editor.xul     Sun Jun 19 00:39:30 2011 -0400
+++ b/editor/ui/composer/content/editor.xul     Sun Jun 19 15:31:00 2011 +0200
@@ -100,7 +100,7 @@
     <commandset id="composerMenuItems"/>
     <commandset id="composerOnlyMenuItems"
                 commandupdater="true"
-                events="create, mode_switch"
+                events="create, style, mode_switch"
                 oncommandupdate="goUpdateComposerMenuItems(this);">
       <!-- file menu -->
       <command id="cmd_exportToText"

Comment 6

6 years ago
Have a look at bug 665265 
I think it is duplicate to this.
(Assignee)

Updated

6 years ago
Duplicate of this bug: 665265

Comment 8

6 years ago
Now I understand how your patch works.
My patch in commant 5 is obsolete.

Comment 9

6 years ago
Comment on attachment 540364 [details] [diff] [review]
Move to correct commandset [Checked in trunk/aurora/beta: Comment 11]

[what does hg diff think it's doing?]
Attachment #540364 - Flags: review?(neil) → review+
(Assignee)

Comment 10

6 years ago
Comment on attachment 540364 [details] [diff] [review]
Move to correct commandset [Checked in trunk/aurora/beta: Comment 11]

Would be good to get this simple regression fix into both aurora and beta.
Attachment #540364 - Flags: approval-comm-beta?
Attachment #540364 - Flags: approval-comm-aurora?

Updated

6 years ago
Attachment #540364 - Flags: approval-comm-beta?
Attachment #540364 - Flags: approval-comm-beta+
Attachment #540364 - Flags: approval-comm-aurora?
Attachment #540364 - Flags: approval-comm-aurora+
(Assignee)

Comment 11

6 years ago
Comment on attachment 540364 [details] [diff] [review]
Move to correct commandset [Checked in trunk/aurora/beta: Comment 11]

http://hg.mozilla.org/comm-central/rev/db68cef40376
http://hg.mozilla.org/releases/comm-aurora/rev/1cb7425596bf
http://hg.mozilla.org/releases/comm-beta/rev/a49dd4679f55
Attachment #540364 - Attachment description: Move to correct commandset → Move to correct commandset [Checked in trunk/aurora/beta: Comment 11]
(Assignee)

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.2

Updated

6 years ago
status-seamonkey2.2: --- → fixed
status-seamonkey2.3: --- → fixed
You need to log in before you can comment on or make changes to this bug.