Last Comment Bug 657219 - Intermittent timeout in browser/base/content/test/tabview/browser_tabview_undo_group.js
: Intermittent timeout in browser/base/content/test/tabview/browser_tabview_und...
Status: VERIFIED FIXED
: intermittent-failure
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: Trunk
: x86 Windows XP
: -- normal
: Firefox 7
Assigned To: Raymond Lee [:raymondlee]
:
:
Mentors:
Depends on:
Blocks: 438871 660175 665844
  Show dependency treegraph
 
Reported: 2011-05-15 08:05 PDT by Tim Taubert [:ttaubert]
Modified: 2016-04-12 14:00 PDT (History)
1 user (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
v1 (1.69 KB, patch)
2011-05-30 22:02 PDT, Raymond Lee [:raymondlee]
ttaubert: feedback-
Details | Diff | Splinter Review
v2 (3.80 KB, patch)
2011-05-31 06:24 PDT, Raymond Lee [:raymondlee]
ttaubert: feedback+
Details | Diff | Splinter Review
v3 (4.68 KB, patch)
2011-05-31 09:16 PDT, Raymond Lee [:raymondlee]
ian: review+
Details | Diff | Splinter Review
Patch for checkin (4.97 KB, patch)
2011-05-31 19:13 PDT, Raymond Lee [:raymondlee]
no flags Details | Diff | Splinter Review

Comment 1 Tim Taubert [:ttaubert] 2011-05-27 02:22:37 PDT
bugspam
Comment 2 Tim Taubert [:ttaubert] 2011-05-27 02:27:33 PDT
bugspam
Comment 3 Raymond Lee [:raymondlee] 2011-05-30 22:02:27 PDT
Created attachment 536231 [details] [diff] [review]
v1

Based on the link in comment 0, the previous test is still running after finish() is called which might be the cause of the problem.
Comment 4 Raymond Lee [:raymondlee] 2011-05-31 01:55:33 PDT
(In reply to comment #3)
> Created attachment 536231 [details] [diff] [review] [review]
> v1
> 
> Based on the link in comment 0, the previous test is still running after
> finish() is called which might be the cause of the problem.

Passed Try:
http://tbpl.mozilla.org/?tree=Try&rev=7febbe87498d
Comment 5 Tim Taubert [:ttaubert] 2011-05-31 02:32:11 PDT
Comment on attachment 536231 [details] [diff] [review]
v1

Review of attachment 536231 [details] [diff] [review]:
-----------------------------------------------------------------

For some reason Utils.log() is used instead of SimpleTest.info() and the first seems to have buffering enabled so that the console message output is slightly delayed. If you exchange that with info() it's perfectly in line.

The test is actually failing here:

>  let closeButton = groupItem.container.getElementsByClassName("close");
>  ok(closeButton, "Group item close button exists");
>  EventUtils.sendMouseEvent({ type: "click" }, closeButton[0], contentWindow);

So maybe we should add a waitForFocus() call for the contentWindow here after the tabview is shown. Alas, I can't see anything obviously intermittent...
Comment 6 Raymond Lee [:raymondlee] 2011-05-31 06:24:07 PDT
Created attachment 536282 [details] [diff] [review]
v2
Comment 7 Tim Taubert [:ttaubert] 2011-05-31 07:08:29 PDT
Comment on attachment 536282 [details] [diff] [review]
v2

Review of attachment 536282 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/base/content/test/tabview/browser_tabview_startup_transitions.js
@@ +42,5 @@
> +
> +        tabViewWindow.document.removeEventListener(
> +          "transitionend", onTransitionEnd, false);
> +
> +        win.close();

Nit: Please add "registerCleanupFunction(function () win.close())" instead of this line to ensure the window gets closed when timing out.
Comment 8 Raymond Lee [:raymondlee] 2011-05-31 09:16:57 PDT
Created attachment 536318 [details] [diff] [review]
v3
Comment 9 Ian Gilman [:iangilman] 2011-05-31 10:11:57 PDT
Comment on attachment 536318 [details] [diff] [review]
v3

Review of attachment 536318 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me
Comment 10 Raymond Lee [:raymondlee] 2011-05-31 19:13:25 PDT
Created attachment 536503 [details] [diff] [review]
Patch for checkin
Comment 11 Tim Taubert [:ttaubert] 2011-05-31 23:01:25 PDT
http://hg.mozilla.org/mozilla-central/rev/316299946b8f
Comment 12 Tim Taubert [:ttaubert] 2011-06-21 00:54:57 PDT
Adding intermittent test failures to new meta bug.

(bugspam)
Comment 13 Virgil Dicu [:virgil] [QA] 2011-08-31 02:43:34 PDT
Setting status to verified fixed based on the results in: http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1314769105.1314770462.11076.gz.

Note You need to log in before you can comment on or make changes to this bug.