process_bug.cgi "redirects" to show_bug.cgi even though preferences set not to show bug

RESOLVED WONTFIX

Status

()

Bugzilla
Creating/Changing Bugs
RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: neil@parkwaycc.co.uk, Unassigned)

Tracking

(Blocks: 1 bug)

Dependency tree / graph

Details

(Reporter)

Description

7 years ago
My user preferences are set to not show the bug after changing it. (And I'm still waiting for a preference for attachments, but that's another story.) But my history is still getting redirected to show_bug.cgi as if I wanted to load the bug, which I don't.

Steps to reproduce problem:
1. Under user preferences, After changing a bug, choose Do Nothing
2. Change a bug
3. Note how process_bug.cgi "redirects" to show_bug.cgi
it looks like the fix on bug 577720 doesn't honour this preference.
Depends on: 577720

Comment 2

7 years ago
  Hmm, I might consider this intentional behavior. Part of what we're doing is ensuring that session restore works properly. Is this causing some negative behavior for you other than that your URL bar says something different?
(Reporter)

Comment 3

7 years ago
(In reply to comment #2)
> Part of what we're doing is ensuring that session restore works properly.
Except that you're restoring something that wasn't there.

> Is this causing some
> negative behavior for you other than that your URL bar says something different?
I guess I'll learn to live with it.

Comment 4

7 years ago
(In reply to comment #3)
> (In reply to comment #2)
> > Part of what we're doing is ensuring that session restore works properly.
> Except that you're restoring something that wasn't there.

  Sure, but it's better than restoring an error page for process_bug.

> I guess I'll learn to live with it.

  Okay. In that case I think I'm going to say WONTFIX for this.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX

Comment 5

7 years ago
How is this bug WONTFIX? If the user pref doesn't work, it should be fixed.

Comment 6

7 years ago
Oh, I see. The content of the page is the expected one. Only the URL has been altered. Then yes, I agree with wontfix here.
You need to log in before you can comment on or make changes to this bug.