Test failure in endurance/testTabView/testSwitchTabs.js

RESOLVED FIXED

Status

Mozilla QA
Mozmill Tests
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: davehunt, Assigned: davehunt)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

7 years ago
The endurance test in endurance/testTabView/testSwitchTabs.js is failing with the following stack:

ERROR | Test Failure: {"exception": {"message": "tabBrowser_openTab: Unknown event type - [object Object]", "lineNumber": 477, "stack": "tabBrowser_openTab([object Proxy])@resource://mozmill/stdlib/securable-module.js -> file:///Users/dave/workspace/mozmill-tests/default/lib/tabs.js:477\n@:0\n", "fileName": "resource://mozmill/stdlib/securable-module.js -> file:///Users/dave/workspace/mozmill-tests/default/lib/tabs.js"}}

According to Henrik this is a regression caused by bug 646021

Comment 1

7 years ago
A Pivotal Tracker story has been created for this Bug: https://www.pivotaltracker.com/story/show/13443863
I'll try to get this fixed this week.
Assignee: nobody → anthony.s.hughes
Status: NEW → ASSIGNED
Regressed by bug 646021. Sorry for that.
Blocks: 646021
Keywords: regression
OS: Mac OS X → All
Hardware: x86 → All
(Assignee)

Updated

7 years ago
Assignee: anthony.s.hughes → dave.hunt
(Assignee)

Comment 4

7 years ago
Created attachment 536565 [details] [diff] [review]
Fixes failing test. v1.0
Attachment #536565 - Flags: review?(hskupin)
Comment on attachment 536565 [details] [diff] [review]
Fixes failing test. v1.0

Looks good, but why do we have to use the button and don't simply remove the parameter completely?
Attachment #536565 - Flags: review?(hskupin) → review+
(Assignee)

Comment 6

7 years ago
Created attachment 536567 [details] [diff] [review]
Fixes failing test. v1.1

(In reply to comment #5)
> Comment on attachment 536565 [details] [diff] [review] [review]
> Fixes failing test. v1.0
> 
> Looks good, but why do we have to use the button and don't simply remove the
> parameter completely?

Done.
Attachment #536565 - Attachment is obsolete: true
Attachment #536567 - Flags: review?(hskupin)
Attachment #536567 - Flags: review?(hskupin) → review+
(Assignee)

Comment 7

7 years ago
Landed as:
http://hg.mozilla.org/qa/mozmill-tests/rev/342d4118876e (default)
http://hg.mozilla.org/qa/mozmill-tests/rev/fa3f15f4e9fa (mozilla-aurora)
http://hg.mozilla.org/qa/mozmill-tests/rev/284113fd94c7 (mozilla-beta)
http://hg.mozilla.org/qa/mozmill-tests/rev/5964166d9e45 (mozilla-2.0)
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.