X to Close "Find in Page' Toolbar Should Be on the Right

RESOLVED WORKSFORME

Status

()

Toolkit
Find Toolbar
--
trivial
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: David E. Ross, Unassigned)

Tracking

2.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20110511 SeaMonkey/2.1
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20110511 SeaMonkey/2.1

Unlike most elements, the X to close the "Find in Page' toolbar is at the left end of its toolbar.  The X to close tabs, the browser window, dialogue popups, etc, are all at the right.  This is confusing and causes the user to search for the X when, habitually, the user generally looks to the right.  

Reproducible: Always

Comment 1

7 years ago
The findbar binding is in toolkit. Moving.
Component: Find In Page → Find Toolbar
OS: Windows XP → All
Product: SeaMonkey → Toolkit
QA Contact: keyboard.fayt → fast.find
Hardware: x86 → All
Version: unspecified → 2.0 Branch
Duplicate of this bug: 265493
Assignee: nobody → mwein2009
Status: NEW → ASSIGNED
Created attachment 558738 [details] [diff] [review]
patch for bug 657438
Attachment #558738 - Flags: review?(gavin.sharp)
Attachment #558738 - Flags: ui-review?(faaborg)
Comment on attachment 558738 [details] [diff] [review]
patch for bug 657438

yep, both internal and external consistency here.
Attachment #558738 - Flags: ui-review?(faaborg) → ui-review+
Comment on attachment 558738 [details] [diff] [review]
patch for bug 657438

Review of attachment 558738 [details] [diff] [review]:
-----------------------------------------------------------------

::: toolkit/content/widgets/findbar.xml
@@ +207,5 @@
>      </resources>
>  
>      <content hidden="true">
>      <xul:hbox anonid="findbar-container" class="findbar-container" flex="1" align="center">
> +#ifdef XP_MAC

Should be #ifdef XP_MACOSX here

@@ +264,5 @@
>        <xul:description anonid="find-status" class="findbar-find-fast findbar-find-status"
>                         control="findbar-textbox">
>        <!-- Do not use value, first child is used because it provides a11y with text change events -->
>        </xul:description>
> +#ifndef XP_MAC

Same here. Replace with XP_MACOSX
Created attachment 562663 [details] [diff] [review]
patch for bug 657438 v2

Minor fixes
Attachment #558738 - Attachment is obsolete: true
Attachment #558738 - Flags: review?(gavin.sharp)
Attachment #562663 - Flags: review?(gavin.sharp)
Comment on attachment 562663 [details] [diff] [review]
patch for bug 657438 v2

r=me pending test results from windows/linux to make sure this works as expected!
Attachment #562663 - Flags: review?(gavin.sharp)
Attachment #562663 - Flags: review+
Attachment #562663 - Flags: feedback?(jwein)
Comment on attachment 562663 [details] [diff] [review]
patch for bug 657438 v2

Review of attachment 562663 [details] [diff] [review]:
-----------------------------------------------------------------

I tested this today on Windows and Linux and it looks good.
Attachment #562663 - Flags: feedback?(jwein) → feedback+
I assume you're going to change the add-on bar too? Otherwise anticipated consistency win will turn into a pretty obvious loss of consistency.
(In reply to Dão Gottwald [:dao] from comment #9)
> I assume you're going to change the add-on bar too? Otherwise anticipated
> consistency win will turn into a pretty obvious loss of consistency.

Filed as bug 689809.

Updated

7 years ago
Depends on: 689809
I noticed that the close button is on the left in IE9's find bar. Does anyone have a broader idea of how applications usually handle this?
The sync notification bar also has the close button on the left...
AFAICT the problem with the find bar is its width.  If we move the close button to the right, users might think it's too far away from everything else...  
However, I still think consistency should have higher priority.  What do you think?
(In reply to Matthew Wein from comment #13)
> AFAICT the problem with the find bar is its width.  If we move the close
> button to the right, users might think it's too far away from everything
> else...  
> However, I still think consistency should have higher priority.  What do you
> think?

To quote faaborg here, "both internal and external consistency here."

On Windows and Linux, close buttons are located on the least-significant side of a window. This is generally good. When a user opens the find bar the first thing the user likely wants to do is use the find bar, not close the find bar.

If we can be consistent and place this close button, as well as the close buttons for other toolbars, on the right side then it will be a positive improvement. If we only move some of the close buttons then the user experience will worsen.
(In reply to Jared Wein [:jwein] from comment #14)
> On Windows and Linux, close buttons are located on the least-significant
> side of a window. This is generally good.

This may not apply to find bars and similar stuff. As I said, IE9 has the close button on the left. Has anyone more data on this?

> When a user opens the find bar the
> first thing the user likely wants to do is use the find bar, not close the
> find bar.

They'll likely want to close it right after using it. We've had, in fact, complaints about the find bar being too persistent.

Updated

2 years ago
Assignee: mwein2009 → nobody
Status: ASSIGNED → NEW

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 16

2 years ago
Yes, the X to close the Find in Page tool bar is now at the right end of the tool bar.  That was not true five years ago, when I submitted this bug report.  Some version of the Toolkit changed it without the responsible developer noting that change in this bug report.
You need to log in before you can comment on or make changes to this bug.