I18N problem, different string after reopening application

RESOLVED DUPLICATE of bug 810172

Status

Thunderbird
Toolbars and Tabs
RESOLVED DUPLICATE of bug 810172
7 years ago
5 years ago

People

(Reporter: Włodzimierz O. Kubera, Unassigned)

Tracking

({helpwanted, intl})

helpwanted, intl

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/534.24 (KHTML, like Gecko) Chrome/11.0.696.68 Safari/534.24
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; pl; rv:1.9.2.17) Gecko/20110414 Thunderbird/3.1.10

String is malformed after reopenning Thunderbird

Reproducible: Always

Steps to Reproduce:
1. Fill in an instant search filter
2. Close the app.
3. Open the app another time

Actual Results:  
Search string is altered without a reason, and the filter stops working

Expected Results:  
No changes in a search string or empty field for searching

I am attaching a screenshot
(Reporter)

Comment 1

7 years ago
Created attachment 532744 [details]
Before closing the app.
(Reporter)

Comment 2

7 years ago
Created attachment 532751 [details]
After closing the app.
confirmed using latest 3.3 nightly,
Status: UNCONFIRMED → NEW
Ever confirmed: true
Looking at the code we probably need to use nsIUnicharOutputStream (and the input version) in our session store manager. We also need to check that it can load old session stores fine as well.
Keywords: helpwanted, intl
OS: Windows 7 → All
Hardware: x86_64 → All
Version: unspecified → 3.1

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 810172
You need to log in before you can comment on or make changes to this bug.