Intermittent mochitest-ipcplugins shutdown timeout

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86_64
Mac OS X
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1305578978.1305583935.13044.gz
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitest-other on 2011/05/16 13:49:38

--DOMWINDOW == 20 (0x127b90f08) [serial = 196] [outer = 0x0] [url = http://mochi.test:8888/tests/modules/plugin/test/test_pluginstream_seek.html]
--DOMWINDOW == 19 (0x128ad89a8) [serial = 207] [outer = 0x12512ef50] [url = http://mochi.test:8888/tests/modules/plugin/test/test_streamNotify.html]
++DOMWINDOW == 20 (0x127caa6f8) [serial = 216] [outer = 0x12512ef50]
--DOCSHELL 0x127dab5c0 == 7
--DOCSHELL 0x128a75c40 == 6
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /builds/slave/cen-osx64-dbg/build/content/base/src/nsContentUtils.cpp, line 2943
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file /builds/slave/cen-osx64-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 327
--DOCSHELL 0x11b5c1880 == 5
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /builds/slave/cen-osx64-dbg/build/content/base/src/nsContentUtils.cpp, line 2943
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file /builds/slave/cen-osx64-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 327
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /builds/slave/cen-osx64-dbg/build/content/base/src/nsContentUtils.cpp, line 2943
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file /builds/slave/cen-osx64-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 327
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /builds/slave/cen-osx64-dbg/build/content/base/src/nsContentUtils.cpp, line 2943
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file /builds/slave/cen-osx64-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 327
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /builds/slave/cen-osx64-dbg/build/content/base/src/nsContentUtils.cpp, line 2943
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file /builds/slave/cen-osx64-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 327
--DOCSHELL 0x11b5d9c70 == 4
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /builds/slave/cen-osx64-dbg/build/content/base/src/nsContentUtils.cpp, line 2943
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file /builds/slave/cen-osx64-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 327
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /builds/slave/cen-osx64-dbg/build/content/base/src/nsContentUtils.cpp, line 2943
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file /builds/slave/cen-osx64-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 327
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /builds/slave/cen-osx64-dbg/build/content/base/src/nsContentUtils.cpp, line 2943
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file /builds/slave/cen-osx64-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 327
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /builds/slave/cen-osx64-dbg/build/content/base/src/nsContentUtils.cpp, line 2943
NPP_Destroy
NPP_Destroy
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /builds/slave/cen-osx64-dbg/build/content/base/src/nsContentUtils.cpp, line 2943
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file /builds/slave/cen-osx64-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 327
--DOCSHELL 0x106a87a90 == 3
WARNING: cannot post event if not initialized: file /builds/slave/cen-osx64-dbg/build/netwerk/protocol/http/nsHttpConnectionMgr.cpp, line 199
NEXT ERROR TEST-UNEXPECTED-FAIL | Shutdown | application timed out after 330 seconds with no output
Can't trigger Breakpad, just killing process
INFO | automation.py | Application ran for: 0:07:19.078809
INFO | automation.py | Reading PID log: /var/folders/H5/H5TD8hgwEqKq9hgKlayjWU+++TM/-Tmp-/tmpGZGv3Cpidlog
(Assuming plugin related until evidence suggests otherwise.)
Component: IPC → Plug-ins
QA Contact: ipc → plugins
(In reply to comment #1)
> (Assuming plugin related until evidence suggests otherwise.)

That last one agrees: ipcplugins was supposed to switch to testing in-process after we switched the default to OOPP, but because 10.6 uses a different pref, it was running both the regular mochitests and ipcplugins out-of-process until bug 667725 landed the other day. Since we've now had shutdown timeouts both in- and out-of-process, I'd bet this bug is a duplicate of one filed on whichever chunk of mochitest runs the same test that's the problem.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

6 years ago
Keywords: intermittent-failure
(Assignee)

Updated

6 years ago
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.