Last Comment Bug 657648 - Don't use high resolution scrolling when acceleration is enabled
: Don't use high resolution scrolling when acceleration is enabled
Status: VERIFIED FIXED
nominated by dao without comment
: regression
Product: Core
Classification: Components
Component: Event Handling (show other bugs)
: Trunk
: x86 Windows 7
: -- major with 1 vote (vote)
: mozilla6
Assigned To: Masayuki Nakano [:masayuki] (Mozilla Japan)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks: 605648 658111
  Show dependency treegraph
 
Reported: 2011-05-17 08:41 PDT by Jim Jeffery not reading bug-mail 1/2/11
Modified: 2013-12-27 14:20 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments
Patch v1.0 (2.42 KB, patch)
2011-05-17 23:43 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan)
bugs: review+
Details | Diff | Splinter Review

Description Jim Jeffery not reading bug-mail 1/2/11 2011-05-17 08:41:04 PDT
This patch seems to have turned off scrolling acceleration.  Used to be the faster you rolled the wheel the further the page would scroll, now it seems linear/flat no matter how fast you roll the wheel.  For those that used this feature it 'feels' like scrolling is now way slower.

Acceleration works: http://hg.mozilla.org/mozilla-central/rev/3e7a21049b6c
Does not work: http://hg.mozilla.org/mozilla-central/rev/0a1e7ec7e268

Modified prefs to set acceleration to user liking, these prefs were in use before bug 605648 landed so I know it was working:
mousewheel.acceleration.factor;5
mousewheel.acceleration.start;3

Prior to landing I can scroll page in one roll of the wheel.  With this patch those settings seem to be ignored or over-written, as it takes 2-3 rolls to scroll the same page.

I have tried turning off the pref: mousewheel.enable_pixel_scrolling
No effect.. scrolling is still not accelerated. 

Tried doubling mousewheel.withnokey.numlines;24 and no effect, still no acceleration. 

If there is no way to return to, or enable accelerated scrolling with wheel, then the page will/could have an undesirable affect on end-users.  I know I'm not liking the change, but I also know you cannot make everyone happy.
Comment 1 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-05-17 23:43:24 PDT
Created attachment 533195 [details] [diff] [review]
Patch v1.0

Disables high resolution scrolling if acceleration is enabled.

# we can disable high resolution scrolling by failing the query event handling in ESM.
Comment 2 Olli Pettay [:smaug] 2011-05-18 11:59:40 PDT
Comment on attachment 533195 [details] [diff] [review]
Patch v1.0

Hmm, why do we have the acceleration, if it is disabled by default?
r=me anyway.
Comment 3 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-05-18 16:36:33 PDT
(In reply to comment #2)
> Hmm, why do we have the acceleration, if it is disabled by default?

On Windows, we cannot know whether the active mouse utility have its owning acceleration or not. If a system had it and enabled it, the scrolling speed is accelerated twice (by utility and us). And not all users want acceleration.

Furthermore, even if we could know the system information, we couldn't compute good speed because user may set the scrolling speed faster for non-acceleration environment.

Anyway, acceleration makes different behavior from other applications. Many users don't want such difference on their desktop.

http://hg.mozilla.org/mozilla-central/rev/b8a035ebdf0f
Comment 4 Jim Jeffery not reading bug-mail 1/2/11 2011-05-19 04:10:00 PDT
Verified fixed, thanks for the quick turn-around.  

Tested on cset: http://hg.mozilla.org/mozilla-central/rev/caba046161e5
Comment 5 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-05-19 04:17:30 PDT
Did you testes with "mousewheel.enable_pixel_scrolling" true?

Now, high resolution scrolling is disabled in default settings.
Comment 6 Jim Jeffery not reading bug-mail 1/2/11 2011-05-19 04:43:11 PDT
(In reply to comment #5)
> Did you testes with "mousewheel.enable_pixel_scrolling" true?
> 
> Now, high resolution scrolling is disabled in default settings.

No I did not, but I just now re-tested, and scrolling is still accelerated with the pref set to 'true'
Comment 7 Masayuki Nakano [:masayuki] (Mozilla Japan) 2011-05-19 04:49:28 PDT
Thank you for your testing and report!

Note You need to log in before you can comment on or make changes to this bug.