Enable Windows high resolution scrolling in default settings

RESOLVED FIXED in mozilla6

Status

()

Core
Widget: Win32
--
enhancement
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: masayuki, Assigned: masayuki)

Tracking

Trunk
mozilla6
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox6-)

Details

(Whiteboard: [tracking+ because this is new feature in 6])

Attachments

(1 attachment)

Now, high resolution scrolling was disabled by bug 657865 due to many regressions. This bug tracks the regressions which must be fixed before re-enabling it.
Depends on: 658153
Created attachment 533526 [details] [diff] [review]
Patch v1.0

I'll request review when all blockers are fixed.
Comment on attachment 533526 [details] [diff] [review]
Patch v1.0

The all patches for the blocker have r+. Would you give r+ for this patch, smaug? If some other regressions would be filed, let's back out only this patch for Fx6.
Attachment #533526 - Flags: review?(Olli.Pettay)

Comment 3

6 years ago
Comment on attachment 533526 [details] [diff] [review]
Patch v1.0

Yeah, if there are any serious regression, better to back this out
immediately.
Attachment #533526 - Flags: review?(Olli.Pettay) → review+
http://hg.mozilla.org/mozilla-central/rev/76a9a3ca4523
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla6

Updated

6 years ago
tracking-firefox6: --- → +

Updated

6 years ago
Whiteboard: potential back out candidate

Comment 5

6 years ago
Sorry if my status Whiteboard note caused confusion or concern. The note was *not* an indication that the release team has evaluated this feature and determined that it needs to be backed out. The Whiteboard note is just a record of why the release team is tracking this issue in the first place -- that it's a new feature that hasn't yet fully proved itself for this release. I've udpated the Whiteboard to say "[tracking+ because this is new feature in 6]" which should hopefully be less alarming.
Whiteboard: potential back out candidate → [tracking+ because this is new feature in 6]

Updated

6 years ago
tracking-firefox6: + → -
You need to log in before you can comment on or make changes to this bug.