Last Comment Bug 657715 - unbreak build for FreeBSD (since it doesn't have libossaudio)
: unbreak build for FreeBSD (since it doesn't have libossaudio)
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Audio/Video (show other bugs)
: Trunk
: All FreeBSD
: -- normal (vote)
: mozilla6
Assigned To: Marco Perez
:
Mentors:
Depends on:
Blocks: 651968
  Show dependency treegraph
 
Reported: 2011-05-17 11:55 PDT by Marco Perez
Modified: 2011-05-18 14:33 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
unbreak build by removing FreeBSD/DragonflyBSD from filter (1.31 KB, patch)
2011-05-17 11:55 PDT, Marco Perez
kinetik: review+
Details | Diff | Splinter Review

Description Marco Perez 2011-05-17 11:55:34 PDT
Created attachment 533030 [details] [diff] [review]
unbreak build by removing FreeBSD/DragonflyBSD from filter

Builds are broken on FreeBSD (and given its origin on DragonflyBSD probably
too) since bug #651968 landed. We should revert the changes for these 2
OSes.
Comment 1 Landry Breuil (:gaston) 2011-05-17 12:21:49 PDT
Duh. My bad, i was pretty sure Free/DragonflyBSD had -lossaudio like Open/NetBSD.

So yes, the diff makes sense to me.
Comment 2 Ludovic Hirlimann [:Usul] 2011-05-18 03:34:12 PDT
Hum maybe you guys want the checkin needed in order to see that in the tree.
Comment 3 Marco Perez 2011-05-18 11:44:23 PDT
Yep, we sure do. :-)

Since there should really be no side-effects for other platforms this should
be safe to land.
Comment 4 Chris Pearce (:cpearce) 2011-05-18 14:31:41 PDT
http://hg.mozilla.org/mozilla-central/rev/666ae6b488a7

Note You need to log in before you can comment on or make changes to this bug.