Auto CC fails to work with Reply-All

RESOLVED WORKSFORME

Status

Thunderbird
Message Compose Window
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: Les Gasser, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.17) Gecko/20110420 Firefox/3.6.17
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.17) Gecko/20110414 Thunderbird/3.1.10

The Auto-CC feature (Tools/Account Settings.../Copies and Folders/When sending messages automatically/"[checkbox] cc these email addresses _____") does not work when replying to messages using the "Reply-all" button on the message display window. 

This auto-cc feature DOES work when using the simple "Reply" button. 

The similar "[checkbox] bcc these email addresses _____" DOES work for BOTH "Reply" and "Reply-all" responses.



Reproducible: Always

Steps to Reproduce:
The Auto-CC feature (Tools/Account Settings.../Copies and Folders/When sending messages automatically/"[checkbox] cc these email addresses _____") does not work when replying to messages using the "Reply-all" button on the message display window. 

This auto-cc feature DOES work when using the simple "Reply" button. 

The similar "[checkbox] bcc these email addresses _____" DOES work for BOTH "Reply" and "Reply-all" responses.

1. Go to "Tools/Account..." as above and check the "[checkbox] cc these email addresses _____". 

2. Fill in an email address in the corresponding textbox. 

3. Close the Account Settings dialog. 

4. Now display an inbox message with multiple recipients, none of which already has the email you just entered in the textbox. 

5. Hit the "reply-all" button and look for the expected auto-cc email address you entered. It's not there.

6. Cancel out of the reply, and display the original multi-recipient message (again).  

7. Now hit the simple "Reply" button. 

8. Now look for the expected auto-cc email address you entered. It DOES appear in the addressee list.

================================================================

To see the expected CORRECT behavior

1. UNCHECK the checkbox "[checkbox] cc these email addresses _____". Then do basically the same test with the similar "auto-bcc" feature: 

2. Check the box and and enter an email in the "[checkbox] bcc these email addresses _____" field. 

3. Then respond to a multi-recipient message with both the "Reply" and "Reply-all" buttons. 

4. You will see the correct behavior in both cases - the "Bcc:" email is filled in. 


Actual Results:  
No CC: with the entered email address appears in the message header when Reply-All is used, but it does appear when "Reply" is used.

Expected Results:  
A cc: with the entered email address should appear in both cases.
OS: Mac OS X → All
Hardware: x86 → All
(Reporter)

Comment 1

7 years ago
Still having this issue, Thunderbird 6.02, as of today's date - Les
Version: unspecified → 6
(Reporter)

Comment 2

2 years ago
Just checked this again with Thunderbird 45.2.0 and the reply-all cc: now appears to be working correctly. So somehow this bug got fixed in the 5-year interim. 

Accordingly I've marked it resolved. (Hope that's correct.) 

- Les
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.