Closed Bug 65848 Opened 20 years ago Closed 19 years ago

The "application/xhtml+xml" MIME Media Type

Categories

(Core :: XML, enhancement)

enhancement
Not set

Tracking

()

VERIFIED FIXED
mozilla0.9.1

People

(Reporter: dmh, Assigned: hjtoi-bugzilla)

References

()

Details

(Keywords: xhtml, Whiteboard: [fixinhand])

Attachments

(3 files)

From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (Win95; I)
BuildID:    2001010901

Over HTTP, when Mozilla is served a file with the application/xhtml+xml media 
type it gives an "Unknown File Type" error.  Could it instead parse it as XML?

For more information see:

    http://www.ietf.org/internet-drafts/draft-baker-xhtml-media-reg-00.txt

Reproducible: Always
Steps to Reproduce:
1. Set up a webserver with the "application/xhtml+xml" MIME Type registered for 
".xhtml" and ".xht" file extensions
2. Place a valid XHTML file on the webserver, with a name like test.xhtml
3. Attempt to see this file in Mozilla

Actual Results:  An "Unknown File Type" error message is displayed

Expected Results:  Displayed the page, treating the file as an XML document
is this a standard or just a draft?
It's an IETF Internet-Draft.
Reporter do you have a testcase we can use?
Attachment is application/xml; Bugzilla wouldn't let me use 
application/xhtml+xml.
reassigning.
Assignee: asa → heikki
Status: UNCONFIRMED → NEW
Component: Browser-General → XML
Ever confirmed: true
QA Contact: doronr → petersen
Setting URL to a test page I already had up for this.

The present IETF Internet-Draft is
http://www.ietf.org/internet-drafts/draft-baker-xhtml-media-reg-01.txt

While parameters like "schema-location" may still be up for debate, it seems a
foregone conclusion that "application/xhtml+xml" will indeed be the official
media type for XHTML.
An additional thought -- shouldn't Mozilla actually treat /all/ XML MIME 
subtypes that it doesn't recognise as if they were application/xml?  For 
example, if I were to open a file with the (fictional) subtype 
application/foobar+xml without a "foobar" plugin or helper app -- Mozilla could 
parse it as XML rather than give the "Unknown File Type" error message.

BTW Robin I agree with your last comment -- and the W3C web site seems to refer 
to it as application/xhtml+xml now rather than just the "XHTML media type".
I should also mention RFC 3023 (XML Media Types) -- 
http://www.ietf.org/rfc/rfc3023.txt -- which discusses the possibility of 
content types like application/mathml+xml and image/svg+xml.
Do other browsers support this and other new MIME types?  
Will try to fix this in M0.9.1 if it isn't too expensive.
Target Milestone: --- → mozilla0.9.1
Neither Opera 5.0 nor MSIE 5.X support "application/xhtml+xml"; Amaya is AFAIK 
the only one.
I have a fix for this and applcation/xml mime type, but they both still exhibit
a bug with view source (you get a file download dialog instead of view source -
doh).
Status: NEW → ASSIGNED
Whiteboard: [fixinhand]
The patch v1.0 fixes this bug, bug 75031 and partially bug 26384.

I discussed the benefits of NS_LITERAL_STRING on netscape.public.mozilla.xpcom.
the mime type related stuff looks good to me, r=valeski. however I don't think 
you need to add the type to nsContentDLF.cpp, do you?
nsContentDLF.cpp changes: Probably not, but since its is still there I'd rather
keep it in sync with nsLayoutDLF.cpp.
r=harishd for patchv1.1
sr=vidur. It's scary how many places needed to change to support the new mime
types. There are going to be more coming down the pipe in the next several
releases...
Fixed.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Marking verified in the May 03rd build. (2001050308)
Status: RESOLVED → VERIFIED
For historical reference, the "application/xhtml+xml" MIME type is not a draft any longer. The registration is published as RFC 3236.
You need to log in before you can comment on or make changes to this bug.