Last Comment Bug 658500 - Adobe InDesign panels are treated as transparent
: Adobe InDesign panels are treated as transparent
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Widget: Cocoa (show other bugs)
: Trunk
: All Mac OS X
: -- normal (vote)
: mozilla6
Assigned To: Markus Stange [:mstange]
:
: Markus Stange [:mstange]
Mentors:
Depends on:
Blocks: 300904
  Show dependency treegraph
 
Reported: 2011-05-20 03:32 PDT by Markus Stange [:mstange]
Modified: 2011-07-20 05:23 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
screenshot (10.88 KB, image/png)
2011-05-20 03:32 PDT, Markus Stange [:mstange]
no flags Details
patch (1.67 KB, patch)
2011-05-20 03:37 PDT, Markus Stange [:mstange]
jaas: review+
Details | Diff | Splinter Review
for checkin (1.89 KB, patch)
2011-05-20 07:43 PDT, Markus Stange [:mstange]
no flags Details | Diff | Splinter Review

Description Markus Stange [:mstange] 2011-05-20 03:32:18 PDT
Created attachment 533922 [details]
screenshot

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0a1) Gecko/20110519 Firefox/6.0a1

This was reported in bug 642423 comment 15.

STR:
1. Move one of Adobe InDesign's panels in front of a Firefox window.
2. Move your mouse over a point where the Firefox window has a bookmarks button
   which is covered by the InDesign panel.

Now a tooltip appears and the button has mouseover feedback, which shouldn't happen.

The problem is that Firefox thinks the panel is transparent to mouse events.
Comment 1 Markus Stange [:mstange] 2011-05-20 03:37:13 PDT
Created attachment 533923 [details] [diff] [review]
patch

The panel has window level kCGFloatingWindowLevel, which we treat as transparent. We shouldn't do that.
I tried to reproduce the Jing window problem I had when I originally wrote this code, but Jing seems to have changed its behavior in the meantime: it now removes its window properly instead of only making it transparent.
We've added the window alpha check in the meantime, so that should make us robust anyway, I think.
Comment 2 Markus Stange [:mstange] 2011-05-20 07:43:53 PDT
Created attachment 533968 [details] [diff] [review]
for checkin
Comment 3 John Hawkinson 2011-05-20 12:43:31 PDT
(In reply to comment #2)
> Created attachment 533968 [details] [diff] [review] [review]
> for checkin

Confirmed, this patch fixes the problem for me. Thanks for the very speedy service!
Comment 4 Dão Gottwald [:dao] 2011-05-22 05:55:33 PDT
http://hg.mozilla.org/mozilla-central/rev/5c7b86a4c7f7
Comment 5 George Carstoiu 2011-07-20 05:10:35 PDT
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0) Gecko/20100101 Firefox/6.0

Does this apply also to any other windows that are dragged in front of Firefox, or does it only apply to Adobe InDesign's panels. I am asking this because I would like to verify this but I don't have Adobe InDesign installed.

Thanks!
Comment 6 John Hawkinson 2011-07-20 05:18:20 PDT
This is not specific to Adobe InDesign, but I think you will have a tough time finding non-Adobe applications that exhibit this. Theoretically anything that uses kCGFloatingWindowLevel windows will see it. (Perhaps Markus knows of some others?)

Note that you can download and install a 30-day free trial of InDesign from http://www.adobe.com/cfusion/tdrc/index.cfm?product=indesign
Comment 7 Markus Stange [:mstange] 2011-07-20 05:23:00 PDT
I don't know of any others, no; it's likely that other Adobe apps like Photoshop use kCGFloatingWindowLevel, too, but I haven't tested.

Note You need to log in before you can comment on or make changes to this bug.