Aurora Dock Icon Broken in 5.0a2 (2011-05-19)

RESOLVED WORKSFORME

Status

()

Firefox
Installer
RESOLVED WORKSFORME
7 years ago
3 months ago

People

(Reporter: Bret Reckard, Unassigned)

Tracking

5 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox5-, firefox6-)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 534144 [details]
View of Broken Doc

After the 5.0a2 (2011-05-19) update in Aurora, the Dock Icon broke.  Next update is available now, so will see if the next Aurora build repairs the issue.

Step 1: Download Build firefox-5.0a2.en-US.mac.dmg - May,18 2011 6:45
Step 2: Install
Step 3: Use browser until May,19 2011 update auto-downloads
Step 4: Install Update and Restart the Browser
Step 5: Browser Restarts with error and Broken Dock Icon (can't recall error :()
Step 6: File Bug
(Reporter)

Comment 1

7 years ago
Upon 2011-05-20 update, 5.0a2 Aurora Icon is still broken
(Reporter)

Updated

7 years ago
tracking-firefox5: --- → ?
Haven't been able to reproduce this. I downloaded ftp://ftp.mozilla.org/pub/firefox/nightly/2011-05-18-04-mozilla-aurora/firefox-5.0a2.en-US.mac.dmg which has a slightly different timestamp, and the dock icon shows fine.
Bret, can you try to reproduce and note the error message? This could have been an error message from an add-on for example.

Updated

7 years ago
tracking-firefox5: ? → +
(Reporter)

Comment 4

7 years ago
I haven't been able to reproduce this error.  I Uninstalled Aurora, and then attempted to reinstall via the .dmg for 5.0a2 (2011-05-19).  Once installed, I clicked *about* Firefox to seek an update.  The update came down and after restarting, everything seems fine.  No error, no broken dock icon.

I'll keep an eye on this, but for now it's not looking reproducible.
Blocks: 659972

Updated

7 years ago
No longer blocks: 659972
Depends on: 659972
This happened to me today on update - as of right now I have the "missing app" icon on my dock for Aurora, and also my F1 addon-on is not in the url bar (where it has been for all previous Aurora updates)
Here's what happened, in case it helps find STR:
* i got told to apply and restart, when i did that the restart hiccupped and seemed to have failed
* so i clicked on the icon to start - that's when the dock icon was replaces with the evil A and i got a message saying the application couldn't be opened
* but then there was updating dialog, the pop up about checking addons
* following that i was able to click on the dock icon again and it did launch but the icon stayed 'missing app' icon
* i went to 'about aurora' and it was downloading an update which i just applied
* however, after restarting (correctly, on its own this time), no dock icon (and no f1 in the url bar)

Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0a2) Gecko/20110601 Firefox/6.0a2
Built from http://hg.mozilla.org/releases/mozilla-aurora/rev/155dea3ad17f
Huh. So I just quit and restarted and the dock icon re-appeared.
Bret: Were you running with F1 as well?
(Reporter)

Comment 8

7 years ago
Current Version: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:6.0a2) Gecko/20110531 Firefox/6.0a2

I'm not running F1

Only have the following installed:
Adblock Plus 1.3.8 (Active)
Feedback 1.1.2 (Active)
BarTab 2.0 (Disabled)
Grafx Bot 0.2.01 (Disabled)
(Reporter)

Comment 9

7 years ago
Also, as an addendum to Comment 4, as this issue reappeared this week.  I think I have a better set of possible steps to reproduce, see below:

It seems this dock icon/error occurs after the First auto-updated nightly is downloaded and installed.  No error message was presented this time around.

Step 1: Download Build firefox-5.0a2.en-US.mac.dmg - May,18 2011 6:45
Step 2: Install
Step 3: Check for updates from *Preferences*
Step 4: Download current nightly and Restart browser
Step 5: Use current browser (Dock Icon is fine) until first auto-updated nightly is available
Step 6: Install Update and Restart the Browser
Step 7: Browser Restarts with Broken Dock Icon
Duplicate of this bug: 662279
(Reporter)

Comment 11

7 years ago
Created attachment 537892 [details]
Message Before Dock Icon Broke

Error message before the Dock Icon broke.

Probably unrelated activity:
1) I checked for updates today from the About Aurora menu and the app said I was up to date
2) I remembered that there was a pending download from the auto-update to install in one of my background windows
3) I started to instill the auto-update and then cancelled the install by clicking "Do not leave page"
4) I returned to the About Aurora menu and this time the app said I had an update avail
5) I clicked the install update button on the About Aurora page
6) After updating, the error attached was presented and the app's icon broke
7) I clicked again on the broken app icon and Aurora seemed to have opened just fine
Are you using --no-remote / more than one profile?
Duplicate of this bug: 605148
This just happened to Hilary on Aurora.
tracking-firefox6: --- → ?
Discussed in triage - this isn't specific to firefox 6, so tracking minus. It's still on the tracking list for 5, so we'll be watching input for user reports here, but we're not sure users will actually hit it (could be channel-switcher specific).
tracking-firefox6: ? → -

Comment 16

7 years ago
My husband reported this today. He had 4.0 and manually installed 5.0 copying over the version in the Applications folder (Mac). The application in the folder was fine, just not on the doc. He deleted the app and installed a new version - it was fine then.
That would imply that this occurs without channel switching.

Comment 18

7 years ago
I had 2 other people report this to me updating from 4.0 to 5.0 as well. I am pretty sure they haven't used the channel switcher. I think they also reinstalled and it disappeared.
From the above comments this doesn't appear to be specific to the installer or the updater. Re-installing fixing this makes sense due to it causing the OS to re-register the application for the dock.

Updated

7 years ago
tracking-firefox5: + → -
Please file a new bug if you see this happening; it's not likely to be the same cause as whatever this was 6 years ago.
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.