Last Comment Bug 659972 - Remove channel switching UI
: Remove channel switching UI
Status: VERIFIED FIXED
[channel-switcher]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 7
Assigned To: :Gavin Sharp [email: gavin@gavinsharp.com]
:
:
Mentors:
Depends on: 663704
Blocks: 658690 660038
  Show dependency treegraph
 
Reported: 2011-05-26 09:19 PDT by :Gavin Sharp [email: gavin@gavinsharp.com]
Modified: 2011-08-04 08:56 PDT (History)
36 users (show)
gavin.sharp: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed
+
fixed


Attachments
simple disable (1.03 KB, patch)
2011-05-30 09:12 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
robert.strong.bugs: review+
margaret.leibovic: feedback+
asa: approval‑mozilla‑beta+
Details | Diff | Splinter Review
trunk patch (remove channel switcher UI entirely) (14.20 KB, patch)
2011-06-02 10:24 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
no flags Details | Diff | Splinter Review
aurora patch - disable switching, leave status text (4.11 KB, patch)
2011-06-02 10:31 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
no flags Details | Diff | Splinter Review
trunk patch (remove channel switcher UI entirely) (11.76 KB, patch)
2011-06-02 11:57 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
no flags Details | Diff | Splinter Review
trunk patch (remove channel switcher UI entirely) (14.76 KB, patch)
2011-06-02 12:02 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
margaret.leibovic: review+
Details | Diff | Splinter Review
aurora patch (trunk patch minus string removals) (12.61 KB, patch)
2011-06-03 10:34 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
asa: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description :Gavin Sharp [email: gavin@gavinsharp.com] 2011-05-26 09:19:14 PDT
I think the channel switching UI isn't likely to be useful to enough users to outweigh the costs (confusing shortcut/app inconsistencies after channel switches, code complexity, testing burden, etc.). Jay seems to agree.

For Firefox 5, perhaps the simplest solution would be to just disable it for the release channel, as it currently is for the nightly channel.
Comment 1 Sheila Mooney 2011-05-26 09:47:33 PDT
So what's a doable target for this? Is this something we should try and get in for FF5? If we remove it, what other things do we need to have...I assume text in the UI explaining how to get on another channel, I know Limi had some ideas here.
Comment 2 :Margaret Leibovic 2011-05-26 10:15:31 PDT
(In reply to comment #1)
> So what's a doable target for this? Is this something we should try and get
> in for FF5? If we remove it, what other things do we need to have...I assume
> text in the UI explaining how to get on another channel, I know Limi had
> some ideas here.

Removing the UI would be easy, but adding text probably wouldn't be possible for Firefox 5 because of localization.
Comment 3 christian 2011-05-26 10:43:39 PDT
I'd say we leave it as-is for Firefox 5 as it is so buried and we know it doesn't leave users broken if they do use it (only that it is ugly/doesn't match product needs in certain cases).
Comment 4 Robert Strong [:rstrong] (use needinfo to contact me) 2011-05-26 12:07:44 PDT
I dislike the idea of there being a release with channel switching ui in it and the next release not having it especially since the ui removal is very straightforward. Especially since this will set the user expectation that they can easily switch back to release when switching from Firefox 5 to Firefox 6 Aurora or Beta.
Comment 5 :Margaret Leibovic 2011-05-26 13:46:05 PDT
(In reply to comment #4)
> Especially since this will set the user expectation that
> they can easily switch back to release when switching from Firefox 5 to
> Firefox 6 Aurora or Beta.

I think this point about being able to get back to Firefox 5 from Aurora or Beta is something very valid to consider. We don't want users to get unintentionally stuck on a different channel because the channel switcher UI is suddenly gone.
Comment 6 Sheila Mooney 2011-05-26 16:28:28 PDT
So I just spoke to the Marketing people about this. They are ok with a solution that just involves removing the "Change" link. They are ok with not changing any text in the about box if that simplifies this. They will probably use the first run pages and such to promote the other channels. We may decide to change the about box in FF6 but we can keep it the same for FF5. 

I need to talk to Erica to make sure she is ok with this then we can move forward unless we find any other blockers to removing this for FF5. I will reply in the bug later tonight when hear back from her.
Comment 7 christian 2011-05-26 16:35:30 PDT
Why would we even bother changing this in Firefox 5? This totally seems like something that can wait for "normal" development and doesn't need to be shoehorned in at the end of the process, for reasons I see in comment 3.

We've already messaged it is there for 5 as well as tested the code as-is extensively...we should just keep it, stop talking about it, and yank it in the next version (my 2c anyway)
Comment 8 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-05-26 16:39:15 PDT
Yanking it after we've shipped it is not optimal, per comment 4/comment 5. Hiding the "Change" link now on Beta is not a risky or complicated change.
Comment 9 christian 2011-05-26 16:43:40 PDT
Ok. Just worried all these "trivial" changes pile up and we ping-pong between different directions, causing excessive churn. I know we are pretty set on removing it but, well, apparently we were adamant it needed to make it in as well. I'll leave that discussion to the post-mortem though.
Comment 10 Dão Gottwald [:dao] 2011-05-28 01:19:14 PDT
(In reply to comment #0)
> confusing shortcut/app inconsistencies after channel switches

I'm not sure what this means, but I guess it's about issues like bug 658690. Is this a concern for the beta channel at all? Maybe we should just exclude aurora like we exclude nightly?
Comment 11 Axel Hecht [:Pike] 2011-05-30 08:37:51 PDT
(In reply to comment #2)
> Removing the UI would be easy, but adding text probably wouldn't be possible
> for Firefox 5 because of localization.

To add, Firefox 6 is string frozen, too.
Comment 12 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-05-30 08:51:35 PDT
(In reply to comment #10)
> I'm not sure what this means, but I guess it's about issues like bug 658690.

Yes, but also bug 649595/bug 649594.

> Is this a concern for the beta channel at all? Maybe we should just exclude
> aurora like we exclude nightly?

That would address the branding inconsistency issues (assuming we maintain the same branding for beta and release - there was talk of changing that too), but it would also reduce the utility of the UI further.
Comment 13 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-05-30 09:12:12 PDT
Created attachment 536113 [details] [diff] [review]
simple disable

This removes the UI entirely for beta/aurora/release channels, to match the behavior of nightly. It's the simplest patch, but perhaps isn't optimal in that it also removes the "current channel" text that informs the user of the channel that they're on. We should probably take this for Firefox 5 (and maybe 6).
Comment 14 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-05-30 09:14:58 PDT
I think the plan here should be:
Firefox 5 (mozilla-beta): disable the UI entirely with the "simple disable" patch
Firefox 6 (mozilla-aurora): disable the switching UI, but keep the "current channel" indicator
Firefox 7 (mozilla-central): remove all of the switching UI (and backend support in bug 660038), keep the "current channel" indicator
Comment 15 Dão Gottwald [:dao] 2011-05-30 09:22:48 PDT
(In reply to comment #12)
> > Is this a concern for the beta channel at all? Maybe we should just exclude
> > aurora like we exclude nightly?
> 
> That would address the branding inconsistency issues (assuming we maintain
> the same branding for beta and release - there was talk of changing that
> too), but it would also reduce the utility of the UI further.

Right, it would just allow end users to easily get on or off the beta channel, nothing more, nothing less. This alone seems like good utility, even though it's less than originally anticipated. Obviously beta would need to keep the release branding then.
Comment 16 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-05-30 10:15:13 PDT
(In reply to comment #15)
> Right, it would just allow end users to easily get on or off the beta
> channel, nothing more, nothing less. This alone seems like good utility

That utility needs to be traded off against the cost of maintaining the code, as well as the release-engineering work of generating extra updates and the QA work involved with testing them.

I am not opposed to keeping the code on trunk while we sort out what we want, but I think we've reached agreement that we should disable it entirely for Firefox 5 (and maybe 6).
Comment 17 :Margaret Leibovic 2011-05-30 12:12:58 PDT
Comment on attachment 536113 [details] [diff] [review]
simple disable

This looks like a safe and easy way to entirely disable the feature if that's what we decide to do.

I don't know if it's worthwhile to keep the feature to just switch between the beta and release channels, although it seems like it would be useful to keep the string that indicates the current channel, since our new version number system doesn't indicate that a build is a beta release.
Comment 18 Sheila Mooney 2011-05-30 21:30:24 PDT
We are getting rid of it because it's fundamentally broken and we really can't find a good value add for the users to justify keeping it. It's better all around if we get rid of it for FF5..just the simpliest option is fine. We understand we publicized it but hey, lots of stuff could end up in Aurora, then get pulled. I have been over this with the product team and we have reached agreement that we should get rid of it.
Comment 19 Robert Kaiser 2011-05-31 04:42:59 PDT
We might remove it now because it's broken, but I think in the end we'll need to end up having some feature like that working some time - but we might be able to worry about it later if we have a really good strategy for advertising the channels and people getting to use them. Judging by the original target numbers, all channels except release have less than half the amount of people that should be there, and Aurora is less than 10% of the ADU we wanted to have there. We'll need some way of getting that evened out - if not the channel switcher, we need other plans. Do those exist?
Comment 20 Sheila Mooney 2011-05-31 09:16:28 PDT
That's a question for the product team. Ultimately they made the call to remove this feature and I know they are looking at ways to evangelize the channels so we can get more users. Your questions are really addressed at Jay, Mayumi and others. To be honest, I don't think the switcher in it's current form will get more people on those channels and neither did they.
Comment 21 Robert Strong [:rstrong] (use needinfo to contact me) 2011-05-31 11:26:39 PDT
For the record...

The "fundamentally broken" part is that channel switching doesn't support changing filesystem names which was just about the very first thing I got UX / product drivers to buy in to (well before the all hands) in that all three installs would identify as "Mozilla Firefox" on Windows and Firefox on Mac (this is due to Mac already being named Firefox). There were also several meetings where there were no objections to this naming and the vast majority of the implementation was completed prior to objections being raised by anyone including product marketing.

There is no additional releng work since it uses existing complete mar files for each repo. There was additional onetime releng work to teach aus to serve up these mar files.
Comment 22 Robert Strong [:rstrong] (use needinfo to contact me) 2011-05-31 11:27:42 PDT
Comment on attachment 536113 [details] [diff] [review]
simple disable

I agree with Gavin's approach in comment #14
Comment 23 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-05-31 12:02:34 PDT
Comment on attachment 536113 [details] [diff] [review]
simple disable

The net effects of this patch is that the entire "You are currently on the XXX update channel. [Change]" block of the about dialog disappears (as it always has for Nightly builds).

I will investigate a slightly more involved change that maintains the text and only removes the link, for Firefox 6.
Comment 24 Sheila Mooney 2011-05-31 16:36:59 PDT
This all sounds good to me. I also agree with Gavin's approach.
Comment 25 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-06-01 14:20:21 PDT
Fixed on mozilla-beta for Firefox 5:
http://hg.mozilla.org/releases/mozilla-beta/rev/ed71a00e8247

I'll attach an aurora patch shortly.
Comment 26 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-06-02 10:24:54 PDT
Created attachment 536921 [details] [diff] [review]
trunk patch (remove channel switcher UI entirely)

This removes all of the channel switching functionality, but maintains the "You are currently on the *foo* update channel." text.
Comment 27 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-06-02 10:31:26 PDT
Created attachment 536927 [details] [diff] [review]
aurora patch - disable switching, leave status text
Comment 28 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-06-02 10:34:39 PDT
(In reply to comment #26)
> trunk patch (remove channel switcher UI entirely)

I suppose I could simplify this further by just moving the gChannelSwitcher.init stuff into to init() and getting rid of gChannelSwitcher - pretend I already did that!
Comment 29 :Margaret Leibovic 2011-06-02 11:27:17 PDT
Comment on attachment 536927 [details] [diff] [review]
aurora patch - disable switching, leave status text

Review of attachment 536927 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/base/content/aboutDialog.js
@@ +591,3 @@
>      // Only show channel selector UI on valid update channels.
>      if (this.channelValue in this.validChannels) {
> +      document.getElementById("channelChangeLink").hidden = false;

If you add back a valid channel, the channel switcher UI will still show all the hard-coded menuitems from aboutDialog.xul. Since this would make for a half-broken feature that we're planning on getting rid of anyway, why don't we just get rid of this if statement entirely?

@@ +639,5 @@
> +
> +    // Use the menuitem label if there is one for this channel, otherwise just
> +    // use the channel value.
> +    let menuItem = document.getElementById(aValue + "Menuitem");
> +    channelLabel.value = menuItem ? menuItem.label : aValue;

It's kind of odd that the only purpose of these menuitems now is to store strings, especially since you decided not to use these strings in your patch for trunk. Maybe we should just set the channel value in init() instead of calling setChannelLabel.
Comment 30 :Margaret Leibovic 2011-06-02 11:45:23 PDT
Comment on attachment 536921 [details] [diff] [review]
trunk patch (remove channel switcher UI entirely)

Review of attachment 536921 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/base/content/aboutDialog.js
@@ +580,2 @@
>      try {
> +      channelValue = Services.prefs.getCharPref("app.update.desiredChannel");

This isn't being set anywhere anymore, so I don't know if we should still check it. I guess as long as the back-end code remains the same a user could manually set the pref to switch channels, but is that worth exposing in our UI? It would be simpler to just look at app.update.channel.
Comment 31 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-06-02 11:57:50 PDT
Created attachment 536948 [details] [diff] [review]
trunk patch (remove channel switcher UI entirely)

OK, so new plan: for aurora, let's just land the trunk patch, but without the string removals.
Comment 32 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-06-02 12:02:10 PDT
Created attachment 536950 [details] [diff] [review]
trunk patch (remove channel switcher UI entirely)

(oops, wrong patch)
Comment 33 :Margaret Leibovic 2011-06-02 12:06:13 PDT
Comment on attachment 536950 [details] [diff] [review]
trunk patch (remove channel switcher UI entirely)

Looks good to me!
Comment 34 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-06-03 10:26:11 PDT
http://hg.mozilla.org/mozilla-central/rev/bb805165115d
Comment 35 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-06-03 10:34:45 PDT
Created attachment 537178 [details] [diff] [review]
aurora patch (trunk patch minus string removals)
Comment 36 Vlad [QA] 2011-06-09 06:01:46 PDT
Verified fixed on Build identifier: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Comment 37 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-06-10 12:25:16 PDT
http://hg.mozilla.org/releases/mozilla-aurora/rev/3d6ab524a848
Comment 38 SuperS_5 2011-06-22 10:14:57 PDT
It would have been nice to keep the function, but disabled/hidden by default with an option to re-enable.  If the feature really was trouble, something similar would be nice.  I switched to beta then to Aurora because of the ease of switching.  Now that I can switch back to use a few plugins, I will have to abandon the beta testing if it is not easy to switch.
Comment 39 Himanshu 2011-06-24 06:44:27 PDT
Yes please include a feature to re-enable Channel Switcher.  It was really useful. Just a click to switch.  And now we'll have to download and then install different channel.
Comment 40 Ling Li 2011-07-08 17:48:54 PDT
I second that this is a useful and welcome feature for beta testers.  I was wondering why I couldn't find the switch button until I found this "bug".  I think it's a mistake to remove the switch button.
Comment 41 bugzilla 2011-07-10 05:30:18 PDT
I really wish it was there - I was just pushed down 6 and it broke almost all of the extensions.  Most importantly, the reddit enhancement suite has been completely broken.  No problem, I thought, I'll just change the channel back to something that I know will work.  But the button is gone.

Please bring it back.
Comment 42 Thomas D. (needinfo?me) 2011-07-17 05:50:34 PDT
(In reply to comment #41)
> I really wish it was there - ...
> Please bring it back.

+1

I was just saying to Wayne that now that Thunderbird is telling me the channel, why don't they implement a channel switcher? The channel switcher would be extremely useful to have for both Firefox and Thunderbird, and make it much more attractive even for technical users like me to test the trunk builds, and if anything goes wrong there, I can just switch back. That's so much easier than all the downloading stuff we've had to do so far.
Comment 43 Mark Banner (:standard8, limited time in Dec) 2011-07-18 00:19:42 PDT
(In reply to comment #42)
> ... and make
> it much more attractive even for technical users like me to test the trunk
> builds, and if anything goes wrong there, I can just switch back. That's so
> much easier than all the downloading stuff we've had to do so far.

Why not just have two (or more) builds installed that you switch between. Then you don't even have to download a new build to switch...
Comment 44 Mark Banner (:standard8, limited time in Dec) 2011-07-18 00:20:38 PDT
(and I just realised discussion like this should probably go onto the newsgroups, as commenting on a fixed bug isn't likely to get followed properly - so please follow up there).

Note You need to log in before you can comment on or make changes to this bug.