Spaces appearing in the rows of a table

RESOLVED DUPLICATE of bug 33784

Status

()

Core
Layout: Tables
P1
normal
RESOLVED DUPLICATE of bug 33784
18 years ago
15 years ago

People

(Reporter: Steve, Unassigned)

Tracking

({testcase})

Trunk
Future
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments, 3 obsolete attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-22 i686)
BuildID:    2001011815

When going to the site http://spl.me.gu.edu.au there seems to be spaces between
the rows of a table on the side.  The page renders correctly and the spaces
*don't* appear in Netscape Communicator, Microsoft Internet Explorer, or Sun
HotJava browsers.

Reproducible: Always
Steps to Reproduce:
1. Go to http://spl.me.gu.edu.au
2. Look at the menu side bar on the left

Actual Results:  While the menu items appear correctly with the red texture in
the background, there are mysterious white spaces between each of the menu
items, which don't appear in the other browsers.

Expected Results:  It should produce a menu where there is a constant 'flow' of
red texture between the menu items.  ie. no white spaces or gaps between each
menu

Maybe it has something to do with how Mozilla renders tables.  Non-standard tags
used, perhaps??
Verified behavior - Mozilla 0.7 release. Screenshot soon.
Created attachment 23008 [details]
Screenshot - spacing
Created attachment 23010 [details]
Testcase
I believe this is a problem with the page. Note the <p align=left>. This should 
create a new line as happened. I think the bug is with the other programs. They 
are probably ignoring the tag because of the "align=left".
http://www.w3.org/TR/html4/struct/text.html#h-9.3.1 Align=left is part of the 
spec, but I'm wondering if other browsers don't know how to handle it.
Created attachment 23011 [details]
fixed testcase
I guess the problem isn't with the align=left because I checked. This has to do 
with a <p> that is the first element on the line inside a link inside a table. 
Then there is an extra line feed.
Created attachment 23022 [details]
Short testcase

Comment 9

18 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 10

18 years ago
QA contact update
QA Contact: chrisd → amar

Comment 11

17 years ago
This is interesting.

http://www.lairweb.org.nz/tiger2/conflict9.html

Apparently same bug. Now go to IE(5.0), load the URL there, then "File->Save
As", then save the whole page (html+images), now load that html file in Mozilla.
Aha! No space anymore. Then I tested it with the url provided by the reporter,
but it didn't work the same way, and the space was still there. Why is that?
Different problems? User's invalid code?
Keywords: testcase

Comment 12

17 years ago
The problem appears in the 2nd attachment by removing all of the rows but 1. The
cell block contains an <a> and returns too large a desired height. -->attinasi
Assignee: karnaze → attinasi

Comment 13

17 years ago
Ack. Looks like residual style fixup is causing some problems.

The markup

<a><p>foo</a>

is getting turned into

<a></a>
<p><a>foo</a>

And that first empty <a> is getting a legitimate height corresponding to the
line height. If we create an empty <a> by itself then it gets no height. I think
we are going to need to know if the empty <a> was caused by a residual style
fixup so we can collapse it, but I need to investigate further.

We have a similar problem outside of tables. Consider this markup:

Line A
<a href="http://www.mozilla.org"
<p>This should be right after Line A
</a>

The same fixup happens, and we end up putting the link two-lines below the text
'Line A'. Interestingly, IE6 ignores the <p> in the <a> and puts the link on the
same line as the text 'Line A'.
Status: NEW → ASSIGNED

Updated

17 years ago
Target Milestone: --- → mozilla1.0.1

Comment 14

17 years ago
Moving Mozilla 1.01 bugs to 'future' milestone with priority P1

I will be pulling bugs from 'future' milestones when scheduling later work.
Priority: -- → P1
Target Milestone: mozilla1.0.1 → Future

Comment 15

16 years ago
I seem to have a similar problem as can be seen in
http://www.privasphere.com/bugs/mozilla/stamp/lineDist.html

The page validates with w3c.org as valid xhtml1.1

The interesting question is: the same html code without indicating which html
version to take renders correctly? 
(see object data tag for the same code again)

win2k, build 2003030408

P.S.: Is this related to http://bugzilla.mozilla.org/show_bug.cgi?id=167632 ?

Comment 16

16 years ago
attinasi will probably not work on those bugs :-(
Assignee: attinasi → table
Status: ASSIGNED → NEW
QA Contact: amar → madhur
Target Milestone: Future → ---

Updated

16 years ago
Target Milestone: --- → Future

Comment 17

15 years ago
Also seeing this in a td containing an img. Extra space appears in either the
margin of the image or the padding of the td; I haven't found a set of CSS rules
that can eliminate this phantom padding/margin.

Comment 18

15 years ago
Created attachment 119917 [details]
demonstrates problem with td containing an img

Comment 19

15 years ago
Comment on attachment 119917 [details]
demonstrates problem with td containing an img

><!DOCTYPE html PUBLIC "-//W3C//XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd"><HTML><HEAD><TITLE>test</TITLE>
>
><STYLE type="" text/css="">
> img {
>  border: 12px solid green;
> }
> td img {
>  border: 0;
> }
> img#problematic {
>  padding: 0;
>  margin-bottom: 0;
> }
> table, table * {
>  border: thin black solid;
>  padding: 0;
> }
> table {
>  background-color: yellow;
> }
></STYLE></HEAD>
>
><BODY>
><TABLE>
><TBODY><TR>
><TD style="padding-bottom: 0pt; background-color: red;"><IMG id="problematic" src="http://www.w3.org/Icons/valid-xhtml10" style="background-color: blue;"/></TD>
></TR>
><TR>
><TD>test</TD>
></TR>
></TBODY></TABLE>
></BODY></HTML>

Comment 20

15 years ago
Created attachment 119920 [details]
demonstrates problem with img in td (screenshot)

Comment 21

15 years ago
Created attachment 119923 [details]
demonstrates problem with td containing an img
Attachment #119917 - Attachment is obsolete: true
Comment 17 through comment 21 have nothing to do with this bug.  (Rather, see
bug 22274.)  Please don't add that much information to a bug if you're not sure
it's related.
Attachment #119923 - Attachment is obsolete: true
Attachment #119920 - Attachment is obsolete: true
This bug is really just a variant of bug 33874 (although a block-within-inline
case).

*** This bug has been marked as a duplicate of 33784 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.