Last Comment Bug 658937 - The Status Bar hides the search results when using Find Again and the Find Bar is closed
: The Status Bar hides the search results when using Find Again and the Find Ba...
Status: RESOLVED FIXED
fixed by bug 171237
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal with 2 votes (vote)
: Firefox 12
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 664628 691206 (view as bug list)
Depends on: 171237
Blocks: 631270
  Show dependency treegraph
 
Reported: 2011-05-22 20:56 PDT by Akkana Peck
Modified: 2012-02-02 00:39 PST (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot showing the url hiding the matched text (154.87 KB, image/jpeg)
2011-05-23 09:29 PDT, Akkana Peck
no flags Details
Screenshot showing matched text that was previously hidden (135.73 KB, image/jpeg)
2011-05-23 09:30 PDT, Akkana Peck
no flags Details

Description Akkana Peck 2011-05-22 20:56:22 PDT
The new URL notifications that show up at the bottom left corner of the page break find-in-page by hiding anything that's been found.

To reproduce: go to a page with a lot of linked text, like
http://pygtk.org/pygtk2tutorial/index.html

Search once in the page for a string that occurs repeatedly, e.g. dialog.
Once you've found it, run "Find again", Ctrl-G.
Notice that the page scrolls, but you can't see where the match is.

The match is at the bottom left of the page -- but it's a link, so the URL notifier popped up right on top of the matched text.

The only way to see whether it actually found a match is to scroll a few lines down (e.g. with the mousewheel).

If this notifier is always going to pop up blocking page content, find-in-page should scroll so that the match is above the notifier, and visible.

Is there a term for the URL popup notifier? I searched for an existing bug, but wasn't sure what term to search for.
Comment 1 Thomas Ahlblom 2011-05-22 22:05:16 PDT
WFM. At least I think so, because I see no obvious problem.
Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110521 Firefox/6.0a1

The "URL notifier" is probably the new Status Bar.

Does the issue still occur if you start Firefox in Safe Mode?
https://support.mozilla.com/en-US/kb/Safe+Mode

How about with a new, empty profile?
https://support.mozilla.com/en-US/kb/Basic+Troubleshooting#w_8-make-a-new-profile
Comment 2 Akkana Peck 2011-05-23 09:21:56 PDT
Yes, I tested it with a brand-new profile before reporting the bug. Same thing happens if I start with that pristine profile in safe mode, and in every profile I have, whether or not they're showing a status/add-ons bar.

Are you not seeing what I describe? Would screenshots help?
Comment 3 Akkana Peck 2011-05-23 09:29:51 PDT
Created attachment 534452 [details]
Screenshot showing the url hiding the matched text

Attaching two screenshots taken with a new profile. The first shows what it looks like right after typing Ctrl-G -- the URL at the bottom is hiding the matched text, so it looks like nothing was found. The second is what it looks like after I mouse out of the window and wait a while for the URL popup to disappear, un-hiding the text.
Comment 4 Akkana Peck 2011-05-23 09:30:39 PDT
Created attachment 534453 [details]
Screenshot showing matched text that was previously hidden
Comment 5 Thomas Ahlblom 2011-05-23 14:20:23 PDT
Reproduced.
Mozilla/5.0 (X11; Linux x86_64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Mozilla/5.0 (X11; Linux x86_64; rv:5.0a2) Gecko/20110523 Firefox/5.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:6.0a1) Gecko/20110523 Firefox/6.0a1
Mozilla/5.0 (Windows NT 6.0; rv:2.0.1) Gecko/20100101 Firefox/4.0.1

Thanks for the screen shots!

When I tested before, the Status Bar always jumped to the right side of the screen, but that was because I didn't close the Find Bar before running Find Again.

Steps to Reproduce:
1. Visit http://pygtk.org/pygtk2tutorial/index.html
2. Open then Find bar and search once for "dialog"
3. Close the Find bar
4. Run "Find Again" multiple times by using Ctrl+G (for Linux and Windows)

Actual Results: The Status Bar hides the search results when they appear to the left at the bottom of the page.

Expected Results:
The status bar doesn't hide the search results, either by scrolling the page upwards or moving the Status Bar to the right of the screen.
Comment 6 Thomas Ahlblom 2011-05-23 15:03:23 PDT
This problem was already pointed out in bug 631270, comment 21, but that bug is VERIFIED FIXED without taking that into account.
Comment 7 keith.stevens 2011-06-02 16:18:19 PDT
I've noticed this behavior, and would definitely appreciate a fix.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Comment 8 Daniel Holbert [:dholbert] (largely AFK until June 28) 2011-06-16 12:57:41 PDT
*** Bug 664628 has been marked as a duplicate of this bug. ***
Comment 9 Adam Nielsen 2011-07-30 21:54:11 PDT
Just came across this one too, very annoying when searching through API pages!  Would've been so much nicer if the old status bar had just stayed put :-)

Mozilla/5.0 (X11; Linux i686 on x86_64; rv:7.0a2) Gecko/20110730 Firefox/7.0a2
Comment 10 Jo Hermans 2011-10-02 16:27:41 PDT
*** Bug 691206 has been marked as a duplicate of this bug. ***
Comment 11 remui42 2011-11-03 06:21:32 PDT
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

The switching of the URL while hovering over a link from left to right works beautifully. However, I have a related issue.
I personally use "Search for text when I start typing" feature, F3 to get to the next result and the bar still being displayed or having popped away does not seem to make a difference.

When finding text on the left side of a page, everything is fine. What, however, if you search for text that is displayed on the right to find matching text that is displayed on the left of a page like, in tables/lists, for example.

Would adding an instruction to hide the hover-over link upon jumping to a next search result and using the present code after the mouse has been moved be possible? Or is a little scrolling up which was mentioned here still on the table?


Actual Results: The Status Bar hides possibly relevant information on the left when the search result is on the right of the page.

Expected Results: Since the browser cannot anticipate what text is supposed to be shown, the complete bottom line should be visible.
Comment 12 Serg Iv 2011-12-16 09:16:25 PST
Yes, guys. This bug is really annoying. Please fix it. Thanks.

Mozilla/5.0 (Windows NT 6.1; rv:8.0.1) Gecko/20111122 Firefox/8.0.1

Note You need to log in before you can comment on or make changes to this bug.