Closed Bug 664628 Opened 11 years ago Closed 11 years ago

Status/link panel gets in way (obscures a find result at bottom-left side of page), if I close findbar & invoke Find Again with F3/Ctrl-G

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 658937

People

(Reporter: dholbert, Unassigned)

References

()

Details

(Keywords: regression, testcase)

Bug 631270 added a hack to prevent the status panel from obscuring links at bottom-left when the find panel was open, but if I continue searching after closing the find panel, its hack stops working.

STEPS TO REPRODUCE: (based on bug 631270)
1. Start Minefield with new profile
2. Open attachment 509483 [details]
3. Press Ctrl + F
4. Type "Firefox" in findbar
5. Press Esc key to close findbar  <--- (this part of the STR is new)
6. Press F3 or Ctrl-G and repeat

ACTUAL RESULTS: Status panel obscures any find results that are at bottom-left of the window.

EXPECTED RESULTS: I should be able to see my find results.

NOTE: (as highlighted with "<--", step 5 in STR is added on top of the original STR from bug 631270, and it's what makes this bug reproducible)
(Adding regression keyword, as this is a regression w.r.t. Firefox 3.6.)
Keywords: regression, testcase
Mozilla/5.0 (X11; Linux x86_64; rv:7.0a1) Gecko/20110614 Firefox/7.0a1
OS: Linux → All
Hardware: x86_64 → All
Summary: Status/link panel gets in way (obscures a find result at bottom-left side of page), if I close findbar & repeat search with Ctrl+G → Status/link panel gets in way (obscures a find result at bottom-left side of page), if I close findbar & invoke Find Again with F3/Ctrl-G
Blocks: 541656
There were some plans to improve the find experience that proposed ensuring find results were vertically centred. That would fix this bug and some others by dealing with the root-cause rather than the symptoms. 

Sadly no individual bug was made for that.
Duplicate of bug 658937?
Mm, looks like it. (specifically, this is a dupe of the updated STR in bug 658937 comment 5 -- the original STR there are more like bug 631270).
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 658937
You need to log in before you can comment on or make changes to this bug.