Width of tabs are not set correctly after closing a not-last tab

VERIFIED INVALID

Status

()

defect
--
minor
VERIFIED INVALID
8 years ago
8 years ago

People

(Reporter: semekh.dev, Unassigned)

Tracking

5 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:5.0) Gecko/20100101 Firefox/5.0
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:5.0) Gecko/20100101 Firefox/5.0

When closing a tab (which is not the last tab), width of the remaining tabs are not set correctly, which causes unused area in the tab bar.

Reproducible: Always

Steps to Reproduce:
1. Try opening many tabs (so that width of tabs equal to min-width)
2. Close one of the tabs (not the last one)

Actual Results:  
Width of the tabs are not increased after closing the tab.

Expected Results:  
Width of the tabs should be increased after closing the tab.

You should use middle click for closing the tab. The issue doesn't occur if you use Ctrl-W.

A simple workaround is to move your mouse a bit so that the tab bar is refreshed.

Comment 1

8 years ago
See Bug 465086
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
Blocks: 465086
Status: RESOLVED → VERIFIED
OS: Linux → All
Hardware: x86 → All
Version: unspecified → 5 Branch
Duplicate of this bug: 665001
You need to log in before you can comment on or make changes to this bug.