Closed Bug 6592 Opened 21 years ago Closed 20 years ago

Rename profiles is not case sensitive (libreg dependency)

Categories

(Core Graveyard :: Profile: BackEnd, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: bijals, Assigned: racham)

References

Details

I ran profile manager according to your instructions: apprunner -ProfileManager.
Next, I clicked on the NEW button to create a new profile called "bijalds".   I
went through the wizard and finally created the "bijalds" profile which was
displayed in the list box next to "defaults".  Next, I decided to rename the new
profile I created to "Bijalds" by clicking on the rename button.  I went to the
rename screen and entered the change.  When I came back to the initial screen, I
only saw "defaults" in the list box and not my new renamed profile "Bijalds".
Status: NEW → ASSIGNED
Target Milestone: M7
This is very strange. This never happened. If Brent or Grace, reproduces this
bug, I will start looking into it.
this does not occur for me on Win or Linux platforms, profile selected is always
renamed and remains in list. (this function is part of smoke test and is tested
on each daily build)
Brent, any comments?
This is the side effect of bug #7132.
If that is resolved, we should not see this behavior.
If Dan Veditz provide some solution to this case sensitivity problem that will
be fine. If not, we will have a mechanism on our end to not create the profile
with the same name.
*** Bug 7128 has been marked as a duplicate of this bug. ***
Target Milestone: M7 → M8
This needs a little time to see what libreg will do.  If libreg gets enhanced,
then we can dup this against 7132, otherwise we need to implement our own fix in
M8.
Depends on: 7132
Summary: Rename profiles functionality does not work → Rename profiles is not case sensitive (libreg dependency)
Target Milestone: M8 → M11
As Bug 7132 set it's TFV to M11, a method to check the existence of profile has
been added. If someone tries to rename with the same name (with a different
case), it prints an error onto the console saying that the profile already
exists and pick a different name. With this fix, all the side-effects in the
past will disappear. The ideal solution will be to have case sensitive model.
So, the real fix will come in when Bug 7132 gets fixed. Moving TFV to M11.
Blocks: 12696
No longer blocks: 12696
Blocks: 12696
These bugs are not critical for beta 1, moving out.
No longer blocks: 12696
Component: Profile Manager → Profile Manager BackEnd
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
We can have profile name in a case sensitive fashion. On windows, directories 
are created with the suffixes -1, -2 and so on, if the profile names are same 
but differ in case. 

Marking this fixed.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
build 2000020709
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.