Remove microsummaries support from SeaMonkey

RESOLVED FIXED in seamonkey2.3

Status

defect
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: InvisibleSmiley, Assigned: InvisibleSmiley)

Tracking

Trunk
seamonkey2.3
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Bug 524091 removed microsummaries support from the platform. As per bug 591807 comment 5 and following, we should remove it from Suite code, too.
Requesting review from Callek for the installer changes and from Neil for the rest.
Attachment #534902 - Flags: superreview?(neil)
Attachment #534902 - Flags: review?(bugspam.Callek)
Comment on attachment 534902 [details] [diff] [review]
patch [Checkin: comment 10]

>-    <menuitem id="placesContext_sortBy:name"
>+   <menuitem id="placesContext_sortBy:name"
Spurious indentation glitch. sr=me with that fixed.
Attachment #534902 - Flags: superreview?(neil) → superreview+
Callek, review ping?
Blocks: 659862
Comment on attachment 534902 [details] [diff] [review]
patch [Checkin: comment 10]

I think this is worth getting into comm-aurora (minus the l10n changes), anyone agree?
Attachment #534902 - Flags: review?(bugspam.Callek)
Attachment #534902 - Flags: review+
Attachment #534902 - Flags: approval-comm-aurora?
> I think this is worth getting into comm-aurora (minus the l10n changes), anyone agree?
Well Bug 659862 is due to the microsummaries being removed from Firefox 6 so if Bug 524091 landed on mozilla-aurora then we better fix our side as well.
Comment on attachment 534902 [details] [diff] [review]
patch [Checkin: comment 10]

a=me (as suggested without the string changes)
Attachment #534902 - Flags: approval-comm-aurora? → approval-comm-aurora+
(In reply to comment #7)
> if Bug 524091 landed on mozilla-aurora then we better fix our side as well.

We need to fix on our side, yes. It didn't land _on aurora_ but it landed on central before it was uplifted to aurora, and therefore it is in what is currently aurora.
Keywords: checkin-needed
Comment on attachment 534902 [details] [diff] [review]
patch [Checkin: comment 10]

http://hg.mozilla.org/comm-central/rev/0155789c1e3c
Attachment #534902 - Attachment description: patch → patch [Checkin: comment 10]
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: c-n: comm-aurora, without string changes
When checking into comm-aurora, please mind both comment 4 and comment 8.
Status: RESOLVED → REOPENED
Keywords: checkin-needed
Resolution: FIXED → ---
Whiteboard: c-n: comm-aurora, without string changes
I don't know how, but I missed to port the change to editBookmarkOverlay.xul so (at least) the New Bookmark dialog is now really broken without this fix.

I'd appreciate if I were allowed to just push this bustage fix instead of having to back out. I'd even volunteer to create a self-contained comm-aurora patch then! :-)
Attachment #537885 - Flags: review?(neil)
Seems I have a recurring off-by-one indentation problem, bah. Fixed locally.
Duplicate of this bug: 659862
Attachment #537885 - Flags: review?(neil) → review+
Comment on attachment 537885 [details] [diff] [review]
bustage fix [Checkin: comment 16]

Given this fixes things correctly, please land on aurora in a single push with the other patch so that nothing breaks.
Attachment #537885 - Flags: approval-comm-aurora+
Comment on attachment 537885 [details] [diff] [review]
bustage fix [Checkin: comment 16]

http://hg.mozilla.org/comm-central/rev/920dffc43f30
Attachment #537885 - Attachment description: bustage fix → bustage fix [Checkin: comment 16]
http://hg.mozilla.org/releases/comm-aurora/rev/1f5bbcd8bdca
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
(In reply to comment #14)
> *** Bug 659862 has been marked as a duplicate of this bug. ***

Mozilla/5.0 (X11; Linux x86_64; rv:7.0a1) Gecko/20110608 Firefox/7.0a1 SeaMonkey/2.4a1 ID:20110608003003

This problem has indeed disappeared now that the present bug is FIXED, see bug 659862 comment #9.
Target Milestone: seamonkey2.2 → seamonkey2.3
You need to log in before you can comment on or make changes to this bug.