OS X mobile nightly fails during optimizejars.py

RESOLVED FIXED in Firefox 6

Status

()

Core
Build Config
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: mfinkle, Assigned: mwu)

Tracking

({regression})

Trunk
mozilla6
regression
Points:
---

Firefox Tracking Flags

(firefox6 fixed, fennec6+)

Details

Attachments

(1 attachment)

IOError: [Errno 2] No such file or directory: '../../dist/fennec/chrome/chrome.jar'
make[2]: *** [stage-package] Error 1
make[1]: *** [default] Error 2
make: *** [package] Error 2

Seems to be happening on nightly and aurora
(Reporter)

Updated

6 years ago
Assignee: nobody → mwu
This regressed between the 5/23 nightly build and the 5/24 nightly build.  Regression range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0f9347d40121&tochange=bb5904c365a2
tracking-fennec: --- → ?
Keywords: regression
(Assignee)

Comment 2

6 years ago
Created attachment 535462 [details] [diff] [review]
Fix path on regular jar packaging case on OSX

This was always broken, but recent changes in bug 600241 made the brokenness actually matter on jar packaged builds.
Attachment #535462 - Flags: review?(ted.mielczarek)
The proposed patch fixes BlueGriffon's universal build on Mac OS X that
failed during postflight_all because of optimizejars.py.
Thanks mwu !!!
OS: Linux → All
Hardware: x86 → All
status-firefox6: --- → affected
Component: General → Build Config
Product: Fennec → Core
QA Contact: general → build-config
(Reporter)

Updated

6 years ago
tracking-fennec: ? → 7+
(Reporter)

Updated

6 years ago
tracking-fennec: 7+ → 6+
Attachment #535462 - Flags: review?(ted.mielczarek) → review+
(Assignee)

Comment 4

6 years ago
http://hg.mozilla.org/mozilla-central/rev/941ceabc5417
Status: NEW → RESOLVED
tracking-fennec: 6+ → ?
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Attachment #535462 - Flags: approval-mozilla-aurora?
Target Milestone: --- → mozilla7

Updated

6 years ago
Attachment #535462 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 5

6 years ago
http://hg.mozilla.org/releases/mozilla-aurora/rev/11e0b7643748
status-firefox6: affected → fixed
Target Milestone: mozilla7 → mozilla6
tracking-fennec: ? → 6+
You need to log in before you can comment on or make changes to this bug.